aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-11-18 10:08:18 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-11-19 14:59:03 +0100
commitd2ee9220515d0bbfe74414c84ef55cff640726ba (patch)
tree5d46e8e7d2f53b527cbe2d8a8e9bc702ff7f655e /target
parent25127f58b42d794bd47d56ea107f3dfc9cc4816c (diff)
downloadupstream-d2ee9220515d0bbfe74414c84ef55cff640726ba.tar.gz
upstream-d2ee9220515d0bbfe74414c84ef55cff640726ba.tar.bz2
upstream-d2ee9220515d0bbfe74414c84ef55cff640726ba.zip
kernel: bump 4.9 to 4.9.202
Refreshed all patches. Altered patches: - 902-debloat_proc.patch Compile-tested on: none Runtime-tested on: none Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/generic/backport-4.9/040-mm-add-support-for-releasing-multiple-instances-of-a.patch2
-rw-r--r--target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch4
-rw-r--r--target/linux/generic/hack-4.9/207-disable-modorder.patch4
-rw-r--r--target/linux/generic/hack-4.9/660-fq_codel_defaults.patch2
-rw-r--r--target/linux/generic/hack-4.9/721-phy_packets.patch4
-rw-r--r--target/linux/generic/hack-4.9/902-debloat_proc.patch4
-rw-r--r--target/linux/generic/pending-4.9/655-increase_skb_pad.patch2
7 files changed, 11 insertions, 11 deletions
diff --git a/target/linux/generic/backport-4.9/040-mm-add-support-for-releasing-multiple-instances-of-a.patch b/target/linux/generic/backport-4.9/040-mm-add-support-for-releasing-multiple-instances-of-a.patch
index d4b60d4559..4656bb1db3 100644
--- a/target/linux/generic/backport-4.9/040-mm-add-support-for-releasing-multiple-instances-of-a.patch
+++ b/target/linux/generic/backport-4.9/040-mm-add-support-for-releasing-multiple-instances-of-a.patch
@@ -41,7 +41,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
--- a/include/linux/gfp.h
+++ b/include/linux/gfp.h
-@@ -506,6 +506,8 @@ extern void free_hot_cold_page(struct pa
+@@ -529,6 +529,8 @@ extern void free_hot_cold_page(struct pa
extern void free_hot_cold_page_list(struct list_head *list, bool cold);
struct page_frag_cache;
diff --git a/target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch b/target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
index 3eae2ef0bd..4fd101db27 100644
--- a/target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
+++ b/target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
@@ -137,7 +137,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
--- a/drivers/net/can/c_can/c_can.c
+++ b/drivers/net/can/c_can/c_can.c
-@@ -1070,7 +1070,7 @@ static int c_can_poll(struct napi_struct
+@@ -1079,7 +1079,7 @@ static int c_can_poll(struct napi_struct
end:
if (work_done < quota) {
@@ -668,7 +668,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
--- a/drivers/net/ethernet/hisilicon/hip04_eth.c
+++ b/drivers/net/ethernet/hisilicon/hip04_eth.c
-@@ -559,7 +559,7 @@ refill:
+@@ -561,7 +561,7 @@ refill:
priv->reg_inten |= RCV_INT;
writel_relaxed(priv->reg_inten, priv->base + PPE_INTEN);
}
diff --git a/target/linux/generic/hack-4.9/207-disable-modorder.patch b/target/linux/generic/hack-4.9/207-disable-modorder.patch
index f03c62e025..62f67ac95d 100644
--- a/target/linux/generic/hack-4.9/207-disable-modorder.patch
+++ b/target/linux/generic/hack-4.9/207-disable-modorder.patch
@@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/Makefile
+++ b/Makefile
-@@ -1228,7 +1228,6 @@ all: modules
+@@ -1240,7 +1240,6 @@ all: modules
PHONY += modules
modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
@$(kecho) ' Building modules, stage 2.';
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.fwinst obj=firmware __fw_modbuild
-@@ -1258,7 +1257,6 @@ _modinst_:
+@@ -1270,7 +1269,6 @@ _modinst_:
rm -f $(MODLIB)/build ; \
ln -s $(CURDIR) $(MODLIB)/build ; \
fi
diff --git a/target/linux/generic/hack-4.9/660-fq_codel_defaults.patch b/target/linux/generic/hack-4.9/660-fq_codel_defaults.patch
index ea461e189d..db77f691e7 100644
--- a/target/linux/generic/hack-4.9/660-fq_codel_defaults.patch
+++ b/target/linux/generic/hack-4.9/660-fq_codel_defaults.patch
@@ -24,4 +24,4 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
+#endif
q->drop_batch_size = 64;
q->quantum = psched_mtu(qdisc_dev(sch));
- q->perturbation = prandom_u32();
+ get_random_bytes(&q->perturbation, sizeof(q->perturbation));
diff --git a/target/linux/generic/hack-4.9/721-phy_packets.patch b/target/linux/generic/hack-4.9/721-phy_packets.patch
index d22c873032..feb3569f04 100644
--- a/target/linux/generic/hack-4.9/721-phy_packets.patch
+++ b/target/linux/generic/hack-4.9/721-phy_packets.patch
@@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
*/
--- a/include/linux/skbuff.h
+++ b/include/linux/skbuff.h
-@@ -2339,6 +2339,10 @@ static inline int pskb_trim(struct sk_bu
+@@ -2340,6 +2340,10 @@ static inline int pskb_trim(struct sk_bu
return (len < skb->len) ? __pskb_trim(skb, len) : 0;
}
@@ -67,7 +67,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
/**
* pskb_trim_unique - remove end from a paged unique (not cloned) buffer
* @skb: buffer to alter
-@@ -2459,16 +2463,6 @@ static inline struct sk_buff *dev_alloc_
+@@ -2460,16 +2464,6 @@ static inline struct sk_buff *dev_alloc_
}
diff --git a/target/linux/generic/hack-4.9/902-debloat_proc.patch b/target/linux/generic/hack-4.9/902-debloat_proc.patch
index 8bed139d1b..cb13f0ff02 100644
--- a/target/linux/generic/hack-4.9/902-debloat_proc.patch
+++ b/target/linux/generic/hack-4.9/902-debloat_proc.patch
@@ -249,10 +249,10 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
#endif
#ifdef CONFIG_PROC_FS
- proc_create("buddyinfo", S_IRUGO, NULL, &fragmentation_file_operations);
-- proc_create("pagetypeinfo", S_IRUGO, NULL, &pagetypeinfo_file_ops);
+- proc_create("pagetypeinfo", 0400, NULL, &pagetypeinfo_file_ops);
+ if (!IS_ENABLED(CONFIG_PROC_STRIPPED)) {
+ proc_create("buddyinfo", S_IRUGO, NULL, &fragmentation_file_operations);
-+ proc_create("pagetypeinfo", S_IRUGO, NULL, &pagetypeinfo_file_ops);
++ proc_create("pagetypeinfo", 0400, NULL, &pagetypeinfo_file_ops);
+ proc_create("zoneinfo", S_IRUGO, NULL, &proc_zoneinfo_file_operations);
+ }
proc_create("vmstat", S_IRUGO, NULL, &proc_vmstat_file_operations);
diff --git a/target/linux/generic/pending-4.9/655-increase_skb_pad.patch b/target/linux/generic/pending-4.9/655-increase_skb_pad.patch
index de96d9a41d..87f9bb6a95 100644
--- a/target/linux/generic/pending-4.9/655-increase_skb_pad.patch
+++ b/target/linux/generic/pending-4.9/655-increase_skb_pad.patch
@@ -9,7 +9,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/include/linux/skbuff.h
+++ b/include/linux/skbuff.h
-@@ -2303,7 +2303,7 @@ static inline int pskb_network_may_pull(
+@@ -2304,7 +2304,7 @@ static inline int pskb_network_may_pull(
* NET_IP_ALIGN(2) + ethernet_header(14) + IP_header(20/40) + ports(8)
*/
#ifndef NET_SKB_PAD