aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDavid Woodhouse <dwmw2@infradead.org>2017-02-15 16:11:12 +0000
committerJohn Crispin <john@phrozen.org>2017-02-17 10:30:38 +0100
commitd16f433e425cc4c64c2ee0b074baee5c668ff1e9 (patch)
tree857094f8e2f50f8c06bffd10d363ecb50224360a /target
parent58fc50f1b088a4bf89b2ce355fc8a4cef3dffcd2 (diff)
downloadupstream-d16f433e425cc4c64c2ee0b074baee5c668ff1e9.tar.gz
upstream-d16f433e425cc4c64c2ee0b074baee5c668ff1e9.tar.bz2
upstream-d16f433e425cc4c64c2ee0b074baee5c668ff1e9.zip
x86: Add Geos profile for Geode subtarget
This makes the Geode images actually useful again. The Geos profile should include the relevant hardware for that board, and the Default profile adds the via-rhine adapter which seems to have been present in the net5501 and alix targets killed in commit 9e0759ea265 ("x86: merge all geode based subtargets into one"). Signed-off-by: David Woodhouse <dwmw2@infradead.org>
Diffstat (limited to 'target')
-rw-r--r--target/linux/x86/geode/profiles/000-Generic.mk20
-rw-r--r--target/linux/x86/geode/profiles/100-Geos.mk19
-rw-r--r--target/linux/x86/geode/target.mk5
3 files changed, 44 insertions, 0 deletions
diff --git a/target/linux/x86/geode/profiles/000-Generic.mk b/target/linux/x86/geode/profiles/000-Generic.mk
new file mode 100644
index 0000000000..58dc3c641c
--- /dev/null
+++ b/target/linux/x86/geode/profiles/000-Generic.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic
+ PACKAGES:= \
+ soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
+ hwclock flashrom tc kmod-pppoa kmod-8139cp kmod-mppe \
+ kmod-usb-ohci-pci kmod-hwmon-lm90 \
+ kmod-via-rhine
+endef
+
+define Profile/Generic/Description
+ Generic Profile for all Geode boards.
+endef
+$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/geode/profiles/100-Geos.mk b/target/linux/x86/geode/profiles/100-Geos.mk
new file mode 100644
index 0000000000..94e501edf4
--- /dev/null
+++ b/target/linux/x86/geode/profiles/100-Geos.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Geos
+ NAME:=Geos
+ PACKAGES:= \
+ soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
+ hwclock flashrom tc kmod-pppoa kmod-8139cp kmod-mppe \
+ kmod-usb-ohci-pci kmod-hwmon-lm90
+endef
+
+define Profile/Geos/Description
+ Traverse Technologies Geos ADSL router
+endef
+$(eval $(call Profile,Geos))
diff --git a/target/linux/x86/geode/target.mk b/target/linux/x86/geode/target.mk
index 4faa49f630..9c608e6f9d 100644
--- a/target/linux/x86/geode/target.mk
+++ b/target/linux/x86/geode/target.mk
@@ -6,6 +6,11 @@ DEFAULT_PACKAGES += \
kmod-button-hotplug \
kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
kmod-ledtrig-netdev hwclock wpad-mini
+# Geos
+DEFAULT_PACKAGES += \
+ soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
+ hwclock flashrom tc kmod-pppoa kmod-8139cp kmod-mppe \
+ kmod-usb-ohci-pci kmod-hwmon-lm90
define Target/Description
Build firmware images for AMD Geode GX/LX based systems (net5501, alix, geos)