aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJiri Kastner <cz172638@gmail.com>2017-01-18 10:45:23 +0100
committerJohn Crispin <john@phrozen.org>2017-01-20 00:35:46 +0100
commitcf79e393f9550dd00e1926168f47d026e3cf72ee (patch)
treec91b9d9dcf1806cca36e9d7d1608ecf07fce55ee /target
parentada6d9fecaf5147db51b7f27c548eb66590d8500 (diff)
downloadupstream-cf79e393f9550dd00e1926168f47d026e3cf72ee.tar.gz
upstream-cf79e393f9550dd00e1926168f47d026e3cf72ee.tar.bz2
upstream-cf79e393f9550dd00e1926168f47d026e3cf72ee.zip
octeon: fix mtd partitions for erlite on cmdline
erlite mtdparts exposes boot0, boot1 and eeprom regions as read/write. this patch adds readonly flags, so these regions can't be modified. same as it is already for ER profile. Signed-off-by: Jiri Kastner <cz172638@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/octeon/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index 62e55dcf5d..299e9ba396 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -35,7 +35,7 @@ define Device/er
endef
TARGET_DEVICES += er
-ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0),512k(boot1),64k@1024k(eeprom) root=/dev/sda2 rootfstype=squashfs,ext4 rootwait
+ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0)ro,512k(boot1)ro,64k(eeprom)ro root=/dev/sda2 rootfstype=squashfs,ext4 rootwait
define Device/erlite
CMDLINE := $(ERLITE_CMDLINE)
DEVICE_TITLE := Ubiquiti EdgeRouter Lite