aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorBjørn Mork <bjorn@mork.no>2021-01-23 11:08:11 +0100
committerPetr Štetiar <ynezz@true.cz>2021-01-24 18:12:34 +0100
commitca4832fcac83bc375a48648bd77d3283d0742128 (patch)
treea846d9766e202e6ff917cabcfdf60d950b8f75ae /target
parent297f82fc583ac277f85a8a202c3d672f93ac08f8 (diff)
downloadupstream-ca4832fcac83bc375a48648bd77d3283d0742128.tar.gz
upstream-ca4832fcac83bc375a48648bd77d3283d0742128.tar.bz2
upstream-ca4832fcac83bc375a48648bd77d3283d0742128.zip
realtek: use vendor-specific magic for ZyXEL
The stock firmware of the ZyXEL GS1900 series use a non-standard u-image magic. This is not enforced by the stock u-boot, which is why we could boot images with the default magic. The flash management application of the stock firmware will however verify the magic, and refuse any image with another value. Convert to vendor-specific value to get flash management support in stock firmware, including the ability to upgrade to OpenWrt directly from stock web UI. Signed-off-by: Bjørn Mork <bjorn@mork.no>
Diffstat (limited to 'target')
-rw-r--r--target/linux/realtek/dts/rtl8380_zyxel_gs1900.dtsi3
-rw-r--r--target/linux/realtek/image/Makefile3
2 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/realtek/dts/rtl8380_zyxel_gs1900.dtsi b/target/linux/realtek/dts/rtl8380_zyxel_gs1900.dtsi
index 5f06339d13..c4441ec30e 100644
--- a/target/linux/realtek/dts/rtl8380_zyxel_gs1900.dtsi
+++ b/target/linux/realtek/dts/rtl8380_zyxel_gs1900.dtsi
@@ -92,7 +92,8 @@
partition@b260000 {
label = "firmware";
reg = <0x260000 0x6d0000>;
- compatible = "denx,uimage";
+ compatible = "openwrt,uimage", "denx,uimage";
+ openwrt,ih-magic = <0x83800000>;
};
partition@930000 {
label = "runtime2";
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index 87c616c3f2..c05c504ec4 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -69,6 +69,7 @@ define Device/zyxel_gs1900-10hp
IMAGE_SIZE := 6976k
DEVICE_VENDOR := ZyXEL
DEVICE_MODEL := GS1900-10HP
+ UIMAGE_MAGIC := 0x83800000
endef
TARGET_DEVICES += zyxel_gs1900-10hp
@@ -79,6 +80,7 @@ define Device/zyxel_gs1900-8hp-v1
DEVICE_MODEL := GS1900-8HP
DEVICE_VARIANT := v1
DEVICE_PACKAGES += lua-rs232
+ UIMAGE_MAGIC := 0x83800000
endef
TARGET_DEVICES += zyxel_gs1900-8hp-v1
@@ -89,6 +91,7 @@ define Device/zyxel_gs1900-8hp-v2
DEVICE_MODEL := GS1900-8HP
DEVICE_VARIANT := v2
DEVICE_PACKAGES += lua-rs232
+ UIMAGE_MAGIC := 0x83800000
endef
TARGET_DEVICES += zyxel_gs1900-8hp-v2