aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-24 19:43:15 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-24 19:43:15 +0000
commitc531ce030165d4c4f3349bb68e09539b6cf4beaf (patch)
tree81444efddd10ea0434fd51ef6b2eaa1b8f305757 /target
parent0a9732d44a671ca726c6040db1f24ea93376db91 (diff)
downloadupstream-c531ce030165d4c4f3349bb68e09539b6cf4beaf.tar.gz
upstream-c531ce030165d4c4f3349bb68e09539b6cf4beaf.tar.bz2
upstream-c531ce030165d4c4f3349bb68e09539b6cf4beaf.zip
fix sound modules loading order and dependencies
SVN-Revision: 32802
Diffstat (limited to 'target')
-rw-r--r--target/linux/ep93xx/modules.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/target/linux/ep93xx/modules.mk b/target/linux/ep93xx/modules.mk
index 94d2c83f82..8b7060ffc7 100644
--- a/target/linux/ep93xx/modules.mk
+++ b/target/linux/ep93xx/modules.mk
@@ -27,10 +27,10 @@ $(eval $(call KernelPackage,input-keyboard-ep93xx))
define KernelPackage/sound-soc-ep93xx
SUBMENU:=$(SOUND_MENU)
TITLE:=EP93xx SoC sound support
- DEPENDS:=@TARGET_ep93xx +kmod-sound-core +kmod-sound-soc-core
+ DEPENDS:=@TARGET_ep93xx +kmod-sound-soc-ac97
KCONFIG:=CONFIG_SND_EP93XX_SOC
FILES:=$(LINUX_DIR)/sound/soc/ep93xx/snd-soc-ep93xx.ko
- AUTOLOAD:=$(call AutoLoad,56,snd-soc-ep93xx)
+ AUTOLOAD:=$(call AutoLoad,57,snd-soc-ep93xx)
endef
define KernelPackage/sound-soc-ep93xx/description
@@ -39,13 +39,15 @@ endef
$(eval $(call KernelPackage,sound-soc-ep93xx))
+# Must be loaded prior to sound-soc-ac97 because it exports
+# soc_ac97_ops
define KernelPackage/sound-soc-ep93xx-ac97
SUBMENU:=$(SOUND_MENU)
TITLE:=EP93xx SoC AC97 support
DEPENDS:=+kmod-sound-soc-ep93xx
KCONFIG:=CONFIG_SND_EP93XX_SOC_AC97
FILES:=$(LINUX_DIR)/sound/soc/ep93xx/snd-soc-ep93xx-ac97.ko
- AUTOLOAD:=$(call AutoLoad,57,snd-soc-ep93xx-ac97)
+ AUTOLOAD:=$(call AutoLoad,56,snd-soc-ep93xx-ac97)
endef
define KernelPackage/sound-soc-ep93xx-ac97/description
@@ -60,7 +62,7 @@ define KernelPackage/sound-soc-ep93xx-simone
DEPENDS:=+kmod-sound-soc-ep93xx +kmod-sound-soc-ep93xx-ac97
KCONFIG:=CONFIG_SND_EP93XX_SOC_SIMONE
FILES:=$(LINUX_DIR)/sound/soc/ep93xx/snd-soc-simone.ko
- AUTOLOAD:=$(call AutoLoad,57,snd-soc-ep93xx)
+ AUTOLOAD:=$(call AutoLoad,59,snd-soc-ep93xx)
endef
define KernelPackage/sound-soc-ep93xx-simone/description