aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMirko Parthey <mirko.parthey@web.de>2017-02-14 15:05:09 +0100
committerRafał Miłecki <rafal@milecki.pl>2017-02-15 23:54:36 +0100
commitbe007c580ec2cd0c76a6a206374ce27d49431891 (patch)
tree58c9ba7c16ba8119d3c7fc6882e94fae7e55fc75 /target
parentdbb8e04472f7d02d55ac8112eb3feaf9a3bd2d95 (diff)
downloadupstream-be007c580ec2cd0c76a6a206374ce27d49431891.tar.gz
upstream-be007c580ec2cd0c76a6a206374ce27d49431891.tar.bz2
upstream-be007c580ec2cd0c76a6a206374ce27d49431891.zip
brcm47xx: fix USB driver choice for Asus WL-500W
BCM4704 SoC has only USB 1.1 core: ssb: Core 3 found: USB 1.1 Hostdev (cc 0x808, rev 0x03, vendor 0x4243) but this device actually comes with two USB 2.0 ports. It appears embedded controller isn't used but instead there are two PCI attached controllers (next to the BCM4321 wireless card): 1106:3038 VT82xx/62xx UHCI USB 1.1 Controller 1106:3104 USB 2.0 Choose a set of USB drivers which actually support this hardware. Signed-off-by: Mirko Parthey <mirko.parthey@web.de> Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm47xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 1bf577e159..8c681ac345 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -300,7 +300,7 @@ TARGET_DEVICES += asus-wl-500gp-v2
define Device/asus-wl-500w
DEVICE_TITLE := Asus WL-500W
- DEVICE_PACKAGES := kmod-b43 $(USB2_PACKAGES)
+ DEVICE_PACKAGES := kmod-b43 kmod-usb-uhci kmod-usb2-pci
$(Device/asus)
PRODUCTID := "WL500W "
endef