aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-10-15 12:52:34 +0200
committerFelix Fietkau <nbd@nbd.name>2019-08-12 11:43:39 +0200
commitb1db6d0539511f60bf65fbde28b16afa31180e34 (patch)
treef536cf119296e3a5f16fd5c5cc06037d606f1842 /target
parent363ce4329d4f6c00b4a7cb83dd1821fafc0d40ad (diff)
downloadupstream-b1db6d0539511f60bf65fbde28b16afa31180e34.tar.gz
upstream-b1db6d0539511f60bf65fbde28b16afa31180e34.tar.bz2
upstream-b1db6d0539511f60bf65fbde28b16afa31180e34.zip
ramips: add preliminary support for SGE AP-MTKH7-0006 developer board
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ramips/dts/AP-MTKH7-0006.dts111
-rw-r--r--target/linux/ramips/image/mt7621.mk11
-rw-r--r--target/linux/ramips/mt7621/config-4.142
4 files changed, 125 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index ca111c9d4c..f7ef126b0d 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -415,6 +415,7 @@ ramips_setup_interfaces()
"0:lan:3" "1:lan:2" "2:lan:1" "3:wan" "6@eth0"
;;
planex,mzk-dp150n|\
+ sge,ap-mtkh7-0006|\
vocore,vocore-8m|\
vocore,vocore-16m)
ucidef_add_switch "switch0" \
diff --git a/target/linux/ramips/dts/AP-MTKH7-0006.dts b/target/linux/ramips/dts/AP-MTKH7-0006.dts
new file mode 100644
index 0000000000..5ab57b2eec
--- /dev/null
+++ b/target/linux/ramips/dts/AP-MTKH7-0006.dts
@@ -0,0 +1,111 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "sge,ap-mtkh7-0006", "mediatek,mt7621-soc";
+ model = "SGE AP-MTKH7-0006";
+
+ chosen {
+ bootargs = "console=ttyS0,57600";
+ };
+
+ wdt@18 {
+ status = "okay";
+ compatible = "linux,wdt-gpio";
+
+ always-running;
+ hw_algo = "level";
+ hw_margin_ms = <60000>;
+ gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+ };
+};
+
+&wdt {
+ status = "disabled";
+};
+
+&spi0 {
+ status = "okay";
+
+ m25p80@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <10000000>;
+ m25p,chunked-io = <32>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x7b0000>;
+ };
+
+ partition@850000 {
+ label = "firmware2";
+ reg = <0x850000 0x7b0000>;
+ };
+ };
+ };
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 4>;
+ mtd-mac-address-increment = <(-2)>;
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "uart2", "uart3", "rgmii2", "sdhci", "wdt";
+ ralink,function = "gpio";
+ };
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ mt76@0,0 {
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ };
+};
+
+&pcie1 {
+ mt76@0,0 {
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x0000>;
+ };
+};
+
+&xhci {
+ status = "disabled";
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d32feb7eab..eeda908c44 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -685,6 +685,17 @@ define Device/xzwifi_creativebox-v1
endef
TARGET_DEVICES += xzwifi_creativebox-v1
+define Device/ap-mtkh7-0006
+ DTS := AP-MTKH7-0006
+ IMAGE_SIZE := $(ralink_default_fw_size_32M)
+ SUPPORTED_DEVICES := sge,ap-mtkh7-0006
+ DEVICE_TITLE := SGE AP-MTKH7-0006
+ DEVICE_PACKAGES := \
+ kmod-sdhci-mt7620 kmod-mt7603 kmod-mt76x2 \
+ kmod-usb3 kmod-usb-ledtrig-usbport wpad-mini
+endef
+TARGET_DEVICES += ap-mtkh7-0006
+
define Device/youhua_wr1200js
MTK_SOC := mt7621
IMAGE_SIZE := 16064k
diff --git a/target/linux/ramips/mt7621/config-4.14 b/target/linux/ramips/mt7621/config-4.14
index a2c58e030b..61aadb3ee2 100644
--- a/target/linux/ramips/mt7621/config-4.14
+++ b/target/linux/ramips/mt7621/config-4.14
@@ -91,6 +91,8 @@ CONFIG_GPIOLIB=y
CONFIG_GPIO_MT7621=y
# CONFIG_GPIO_RALINK is not set
CONFIG_GPIO_SYSFS=y
+CONFIG_GPIO_WATCHDOG=y
+CONFIG_GPIO_WATCHDOG_ARCH_INITCALL=y
# CONFIG_GRO_CELLS is not set
CONFIG_HANDLE_DOMAIN_IRQ=y
CONFIG_HARDWARE_WATCHPOINTS=y