aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-04 17:30:54 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-04 17:30:54 +0000
commitac68f0d8fa38b998fbaa8098a5d20dc59d838801 (patch)
tree6d66701af0ea9b35ac4a41cae4035bc5f2316e1b /target
parent923e5d35434d9bd13d108b2d216978eff169844b (diff)
downloadupstream-ac68f0d8fa38b998fbaa8098a5d20dc59d838801.tar.gz
upstream-ac68f0d8fa38b998fbaa8098a5d20dc59d838801.tar.bz2
upstream-ac68f0d8fa38b998fbaa8098a5d20dc59d838801.zip
ar71xx: add profile and build image for the TL-WA701N/ND boards
SVN-Revision: 29656
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk11
-rw-r--r--target/linux/ar71xx/image/Makefile6
2 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index c9f0cacb1e..2b9aa0e218 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -50,6 +50,17 @@ endef
$(eval $(call Profile,TLWR703))
+define Profile/TLWA701
+ NAME:=TP-LINK TL-WA701N/ND
+ PACKAGES:=
+endef
+
+define Profile/TLWA701/Description
+ Package set optimized for the TP-LINK TL-WA701N/ND.
+endef
+$(eval $(call Profile,TLWA701))
+
+
define Profile/TLWA901
NAME:=TP-LINK TL-WA901N/ND
PACKAGES:=
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 4b90429edd..0a52b63755 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -780,6 +780,11 @@ define Image/Build/Profile/TLMR3420
$(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-mr3420-v1,$(tlmr3420_cmdline),0x34200001,1,4M)
endef
+tlwa701_cmdline=board=TL-WA901ND console=ttyS0,115200
+define Image/Build/Profile/TLWA701
+ $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-wa701n-v1,$(tlwa701_cmdline),0x07010001,1,4M)
+endef
+
tlwa901_cmdline=board=TL-WA901ND console=ttyS0,115200
tlwa901v2_cmdline=board=TL-WA901ND-v2 console=ttyS0,115200
define Image/Build/Profile/TLWA901
@@ -941,6 +946,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/TLMR3020,$(1))
$(call Image/Build/Profile/TLMR3220,$(1))
$(call Image/Build/Profile/TLMR3420,$(1))
+ $(call Image/Build/Profile/TLWA701,$(1))
$(call Image/Build/Profile/TLWA901,$(1))
$(call Image/Build/Profile/TLWR703,$(1))
$(call Image/Build/Profile/TLWR740,$(1))