aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-26 17:01:44 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-26 17:01:44 +0000
commita5538a18d428f29e314c16c27ec8965bf58a0805 (patch)
treec129adaae2995cd861849efdd62324d1fe505fd9 /target
parent1338af2640f3b210c7b8d6d834bf1bf96fea333c (diff)
downloadupstream-a5538a18d428f29e314c16c27ec8965bf58a0805.tar.gz
upstream-a5538a18d428f29e314c16c27ec8965bf58a0805.tar.bz2
upstream-a5538a18d428f29e314c16c27ec8965bf58a0805.zip
ar71xx: create a profile and build images for Compex WPE72
[juhosg: remove ath9k from the the profile package list, build WPE72 image with the Default profile as well] Signed-off-by: Johnathan Boyce <jon.boyce@globalreach.eu.com> SVN-Revision: 29914
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/generic/profiles/compex.mk11
-rw-r--r--target/linux/ar71xx/image/Makefile6
2 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/compex.mk b/target/linux/ar71xx/generic/profiles/compex.mk
index 38d963a5c1..3491473810 100644
--- a/target/linux/ar71xx/generic/profiles/compex.mk
+++ b/target/linux/ar71xx/generic/profiles/compex.mk
@@ -15,3 +15,14 @@ define Profile/WP543/Description
endef
$(eval $(call Profile,WP543))
+
+define Profile/WPE72
+ NAME:=Compex WPE72/WPE72NX
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/WPE72/Description
+ Package set optimized for the Compex WPE72 boards including Compex WPE72NX Indoor Access Point.
+endef
+
+$(eval $(call Profile,WPE72))
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index a5672869f1..4e538b8b70 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -684,6 +684,11 @@ define Image/Build/Profile/WP543
$(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wp543,$(wp543_cmdline),0x1000000,16M)
endef
+wpe72_cmdline=console=ttyS0,115200
+define Image/Build/Profile/WPE72
+ $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wpe72,$(wpe72_cmdline),0x800000,8M)
+endef
+
dir600a1_cmdline=board=DIR-600-A1 console=ttyS0,115200
define Image/Build/Profile/DIR600A1
$(call Image/Build/Template/$(fs_64k)/$(1),Cameo7240,dir-600-a1,$(dir600a1_cmdline),"AP91-AR7240-RT-090223-00")
@@ -1011,6 +1016,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/TLWR2543,$(1))
$(call Image/Build/Profile/UBNT,$(1))
$(call Image/Build/Profile/WP543,$(1))
+ $(call Image/Build/Profile/WPE72,$(1))
$(call Image/Build/Profile/WNDR3700,$(1))
$(call Image/Build/Profile/AP96,$(1))
$(call Image/Build/Profile/WRT400N,$(1))