aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-12-27 20:33:57 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-12-27 20:33:57 +0100
commit9d96b6fb720d9cecc7bd50b4f16dabe1b337f9f2 (patch)
treead53ca3fdf54309ef4537fff3ae3d00f647a0483 /target
parent1fb40a72da115073b55ed1b92b443c1b80794c44 (diff)
downloadupstream-9d96b6fb720d9cecc7bd50b4f16dabe1b337f9f2.tar.gz
upstream-9d96b6fb720d9cecc7bd50b4f16dabe1b337f9f2.tar.bz2
upstream-9d96b6fb720d9cecc7bd50b4f16dabe1b337f9f2.zip
ath79/mikrotik: disable building NAND images
The current support for MikroTik NAND-based devices relies on a gross hack that packs the kernel into a static YAFFS stub, as the stock bootloader only supports booting a YAFFS-encapsulated kernel. The problem with this approach is that since the kernel partition is blindly overwritten without any kind of wear or badblock management (due to lack of proper support for YAFFS in OpenWRT), the NAND flash is not worn uniformly and eventually badblocks appear, leading to unbootable devices. This issue has been reported here [1] and discussed in more detail here [2]. [1] https://forum.openwrt.org/t/rb433-bad-sector-cannot-start-openwrt/71519 [2] https://github.com/openwrt/openwrt/pull/3026#issuecomment-673597461 Until a proper fix is found (or the stock bootloader supports other filesystems), we disable building these images to prevent unknowing users from risking their devices. Thanks to Thibaut Varène for summarizing the details above. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/image/common-mikrotik.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ath79/image/common-mikrotik.mk b/target/linux/ath79/image/common-mikrotik.mk
index b0c3feda20..6e739f2d85 100644
--- a/target/linux/ath79/image/common-mikrotik.mk
+++ b/target/linux/ath79/image/common-mikrotik.mk
@@ -17,4 +17,5 @@ define Device/mikrotik_nand
IMAGE/sysupgrade.bin = append-kernel | kernel2minor -s 2048 -e -c | \
sysupgrade-tar kernel=$$$$@ | append-metadata
DEVICE_PACKAGES := nand-utils
+ DEFAULT := n
endef