aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMichal Cieslakiewicz <michal.cieslakiewicz@wp.pl>2019-10-31 21:18:10 +0100
committerJohn Crispin <john@phrozen.org>2019-11-02 19:29:30 +0100
commit9b6f89c37fc9c2e23cc123bd7b5cf9a1f8dc301a (patch)
tree49de35938d17ba41c1cb6ba682eb554f3f6bc016 /target
parentaffe633be4c8122835e255425418ba1680a652e3 (diff)
downloadupstream-9b6f89c37fc9c2e23cc123bd7b5cf9a1f8dc301a.tar.gz
upstream-9b6f89c37fc9c2e23cc123bd7b5cf9a1f8dc301a.tar.bz2
upstream-9b6f89c37fc9c2e23cc123bd7b5cf9a1f8dc301a.zip
ath79: add support for Netgear WNDR4300
This patch adds ath79 support for Netgear WNDR4300. Router was previously supported by ar71xx target only. Note: device requires 'ar934x-nand' driver in kernel. Specification ============= * Description: Netgear WNDR4300 * Loader: U-boot * SOC: Atheros AR9344 (560 MHz) * RAM: 128 MiB * Flash: 128 MiB (NAND) - U-boot binary: 256 KiB - U-boot environment: 256 KiB - ART: 256 KiB - POT: 512 KiB - Language: 2 MiB - Config: 512 KiB - Traffic Meter: 3 MiB - Firmware: 25 MiB - ART Backup: 256 KiB - Reserved: 96 MiB * Ethernet: 5 x 10/100/1000 (4 x LAN, 1 x WAN) (AR8327) * Wireless: - 2.4 GHz b/g/n (internal) - 5 GHz a/n (AR9580) * USB: yes, 1 x USB 2.0 * Buttons: - Reset - WiFi (rfkill) - WPS * LEDs: - Power (amber/green) - WAN (amber/green) - WLAN 2G (green) - WLAN 5G (blue) - 4 x LAN (amber/green) - USB (green) - WPS (amber/green) * UART: 4-pin connector JP1, 3.3V (Vcc, TX, RX, GND), 115200 8N1 * Power supply: DC 12V 2.5A * MAC addresses: LAN=WLAN2G on case label, WAN +1, WLAN5G +2 Installation ============ * TFTP recovery * TFTP via U-boot prompt * sysupgrade * Web interface Note about partitioning: firmware partition offset (0x6c0000) is hardcoded into vendor's u-boot, so this partition cannot be moved and resized to include Netgear-specific flash areas (pot, language, config, traffic_meter) not used by OpenWrt. Test build configuration ======================== CONFIG_TARGET_ath79=y CONFIG_TARGET_ath79_nand=y CONFIG_TARGET_ath79_nand_DEVICE_netgear_wndr4300=y CONFIG_ALL_KMODS=y CONFIG_DEVEL=y CONFIG_CCACHE=y CONFIG_COLLECT_KERNEL_DEBUG=y CONFIG_IMAGEOPT=y Signed-off-by: Michal Cieslakiewicz <michal.cieslakiewicz@wp.pl>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/dts/ar9344_netgear_wndr4300.dts293
-rw-r--r--target/linux/ath79/image/nand.mk32
-rwxr-xr-xtarget/linux/ath79/nand/base-files/etc/board.d/01_leds3
-rwxr-xr-xtarget/linux/ath79/nand/base-files/etc/board.d/02_network7
-rw-r--r--target/linux/ath79/nand/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom13
-rw-r--r--target/linux/ath79/nand/base-files/lib/upgrade/platform.sh1
6 files changed, 349 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/ar9344_netgear_wndr4300.dts b/target/linux/ath79/dts/ar9344_netgear_wndr4300.dts
new file mode 100644
index 0000000000..c2c395e8cf
--- /dev/null
+++ b/target/linux/ath79/dts/ar9344_netgear_wndr4300.dts
@@ -0,0 +1,293 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar9344.dtsi"
+
+/ {
+ compatible = "netgear,wndr4300", "qca,ar9344";
+ model = "Netgear WNDR4300";
+
+ chosen {
+ bootargs = "console=ttyS0,115200n8";
+ };
+
+ aliases {
+ led-boot = &power_amber;
+ led-failsafe = &power_amber;
+ led-running = &power_green;
+ led-upgrade = &power_amber;
+ label-mac-device = &eth0;
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ wps {
+ label = "wps";
+ linux,code = <KEY_WPS_BUTTON>;
+ gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+ };
+
+ reset {
+ label = "reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 21 GPIO_ACTIVE_LOW>;
+ };
+
+ rfkill {
+ label = "rfkill";
+ linux,code = <KEY_RFKILL>;
+ gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ pinctrl-names = "default";
+ pinctrl-0 = <&enable_gpio_11>;
+
+ power_green: power_green {
+ label = "netgear:green:power";
+ gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
+ };
+
+ power_amber: power_amber {
+ label = "netgear:amber:power";
+ gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+ default-state = "keep";
+ };
+
+ wan_green {
+ label = "netgear:green:wan";
+ gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+ };
+
+ wan_amber {
+ label = "netgear:amber:wan";
+ gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan2g_green {
+ label = "netgear:green:wlan2g";
+ gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ wlan5g_blue {
+ label = "netgear:blue:wlan5g";
+ gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy1tpt";
+ };
+
+ wps_green {
+ label = "netgear:green:wps";
+ gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+ };
+
+ wps_amber {
+ label = "netgear:amber:wps";
+ gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+ };
+
+ usb_green {
+ label = "netgear:green:usb";
+ gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+ trigger-sources = <&hub_port>;
+ linux,default-trigger = "usbport";
+ };
+ };
+};
+
+&pinmux {
+ enable_gpio_11: pinmux_enable_gpio_11 {
+ pinctrl-single,bits = <0x8 0x0 0xff000000>;
+ };
+};
+
+&nand {
+ status = "okay";
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x40000>;
+ read-only;
+ };
+
+ partition@40000 {
+ label = "u-boot-env";
+ reg = <0x40000 0x40000>;
+ };
+
+ art: partition@80000 {
+ label = "caldata";
+ reg = <0x80000 0x40000>;
+ read-only;
+ };
+
+ partition@c0000 {
+ label = "pot";
+ reg = <0xc0000 0x80000>;
+ };
+
+ partition@140000 {
+ label = "language";
+ reg = <0x140000 0x200000>;
+ };
+
+ partition@340000 {
+ label = "config";
+ reg = <0x340000 0x80000>;
+ };
+
+ partition@3c0000 {
+ label = "traffic_meter";
+ reg = <0x3c0000 0x300000>;
+ };
+
+ kernel@6c0000 {
+ label = "kernel";
+ reg = <0x6c0000 0x200000>;
+ };
+
+ ubi@8c0000 {
+ label = "ubi";
+ reg = <0x8c0000 0x1700000>;
+ };
+
+ partition@6c0000 {
+ label = "firmware";
+ reg = <0x6c0000 0x1900000>;
+ compatible = "netgear,uimage";
+ };
+
+ partition@1fc0000 {
+ label = "caldata_backup";
+ reg = <0x1fc0000 0x40000>;
+ read-only;
+ };
+
+ partition@2000000 {
+ label = "reserved";
+ reg = <0x2000000 0x6000000>;
+ read-only;
+ };
+ };
+};
+
+&ref {
+ clock-frequency = <40000000>;
+};
+
+&builtin_switch {
+ resets = <&rst 8>, <&rst 12>;
+ reset-names = "switch", "switch-analog";
+};
+
+&mdio0 {
+ status = "okay";
+
+ phy-mask = <0>;
+
+ phy0: ethernet-phy@0 {
+ reg = <0>;
+ phy-mode = "rgmii";
+ qca,mib-poll-interval = <500>;
+
+ qca,ar8327-initvals = <
+ 0x04 0x07600000
+ 0x0c 0x01000000
+ 0x10 0xc1000000
+ 0x50 0xcc35cc35
+ 0x54 0xcb37cb37
+ 0x58 0x00000000
+ 0x5c 0x00f3cf00
+ 0x7c 0x0000007e
+ 0x94 0x0000007e
+ >;
+ };
+};
+
+&eth0 {
+ status = "okay";
+
+ /* default for ar934x, except for 1000M */
+ pll-data = <0x06000000 0x00000101 0x00001616>;
+
+ mtd-mac-address = <&art 0x0>;
+
+ phy-mode = "rgmii";
+ phy-handle = <&phy0>;
+};
+
+&gpio {
+ status = "okay";
+
+ lna0 {
+ gpio-hog;
+ line-name = "netgear:ext:lna0";
+ gpios = <18 GPIO_ACTIVE_HIGH>;
+ output-high;
+ };
+
+ lna1 {
+ gpio-hog;
+ line-name = "netgear:ext:lna1";
+ gpios = <19 GPIO_ACTIVE_HIGH>;
+ output-high;
+ };
+};
+
+&wmac {
+ status = "okay";
+
+ mtd-mac-address = <&art 0x0>;
+ qca,no-eeprom;
+};
+
+&pcie {
+ status = "okay";
+
+ ath9k: wifi@0,0 {
+ compatible = "pci168c,0033";
+ reg = <0x0000 0 0 0 0>;
+ mtd-mac-address = <&art 0xc>;
+ qca,no-eeprom;
+ #gpio-cells = <2>;
+ gpio-controller;
+
+ usb_power {
+ gpio-hog;
+ line-name = "netgear:power:usb";
+ gpios = <0 GPIO_ACTIVE_HIGH>;
+ output-high;
+ };
+ };
+};
+
+&usb_phy {
+ status = "okay";
+};
+
+&usb {
+ status = "okay";
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ hub_port: port@1 {
+ reg = <1>;
+ #trigger-source-cells = <0>;
+ };
+};
+
+&uart {
+ status = "okay";
+};
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index c11ff6a257..0f7514060e 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -1,3 +1,5 @@
+include ./common-netgear.mk # for netgear-uImage
+
# attention: only zlib compression is allowed for the boot fs
define Build/zyxel-buildkerneljffs
rm -rf $(KDIR_TMP)/zyxelnbg6716
@@ -59,6 +61,36 @@ define Device/glinet_gl-ar300m-nand
endef
TARGET_DEVICES += glinet_gl-ar300m-nand
+# fake rootfs is mandatory, pad-offset 129 equals (2 * uimage_header + 0xff)
+define Device/netgear_ath79_nand
+ DEVICE_VENDOR := NETGEAR
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport
+ KERNEL_SIZE := 2048k
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ IMAGE_SIZE := 25600k
+ KERNEL := kernel-bin | append-dtb | lzma -d20 | \
+ pad-offset $$(KERNEL_SIZE) 129 | \
+ netgear-uImage lzma | append-string -e '\xff' | \
+ append-uImage-fakehdr filesystem $$(NETGEAR_KERNEL_MAGIC)
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma -d20 | netgear-uImage lzma
+ IMAGES := sysupgrade.bin factory.img
+ IMAGE/factory.img := append-kernel | append-ubi | netgear-dni | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata | check-size $$$$(IMAGE_SIZE)
+ UBINIZE_OPTS := -E 5
+endef
+
+define Device/netgear_wndr4300
+ ATH_SOC := ar9344
+ DEVICE_MODEL := WNDR4300
+ NETGEAR_KERNEL_MAGIC := 0x33373033
+ NETGEAR_BOARD_ID := WNDR4300
+ NETGEAR_HW_ID := 29763948+0+128+128+2x2+3x3
+ SUPPORTED_DEVICES += wndr4300
+ $(Device/netgear_ath79_nand)
+endef
+TARGET_DEVICES += netgear_wndr4300
+
define Device/zyxel_nbg6716
ATH_SOC := qca9558
DEVICE_VENDOR := ZyXEL
diff --git a/target/linux/ath79/nand/base-files/etc/board.d/01_leds b/target/linux/ath79/nand/base-files/etc/board.d/01_leds
index 59c35ed828..f851b3d886 100755
--- a/target/linux/ath79/nand/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/nand/base-files/etc/board.d/01_leds
@@ -11,6 +11,9 @@ case "$board" in
glinet,gl-ar300m-nand)
ucidef_set_led_netdev "lan" "LAN" "gl-ar300m:green:lan" "eth0"
;;
+netgear,wndr4300)
+ ucidef_set_led_switch "wan-amber" "WAN (amber)" "netgear:amber:wan" "switch0" "0x20"
+ ;;
esac
board_config_flush
diff --git a/target/linux/ath79/nand/base-files/etc/board.d/02_network b/target/linux/ath79/nand/base-files/etc/board.d/02_network
index faf70218ac..9d7a19c2eb 100755
--- a/target/linux/ath79/nand/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/nand/base-files/etc/board.d/02_network
@@ -11,6 +11,10 @@ ath79_setup_interfaces()
aerohive,hiveap-121)
ucidef_set_interface_lan "eth0"
;;
+ netgear,wndr4300)
+ ucidef_add_switch "switch0" \
+ "0@eth0" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1" "5:wan"
+ ;;
zyxel,nbg6716)
ucidef_add_switch "switch0" \
"0@eth0" "1:lan" "2:lan" "3:lan" "4:lan" "5:wan" "6@eth1"
@@ -26,6 +30,9 @@ ath79_setup_macs()
local board="$1"
case "$board" in
+ netgear,wndr4300)
+ wan_mac=$(mtd_get_mac_binary caldata 0x6)
+ ;;
zyxel,nbg6716)
lan_mac=$(macaddr_add $(mtd_get_mac_ascii u-boot-env ethaddr) +2)
wan_mac=$(macaddr_add $(mtd_get_mac_ascii u-boot-env ethaddr) +3)
diff --git a/target/linux/ath79/nand/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom b/target/linux/ath79/nand/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
index 88a40b5d41..ae1d3572a8 100644
--- a/target/linux/ath79/nand/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
+++ b/target/linux/ath79/nand/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
@@ -9,6 +9,9 @@ board=$(board_name)
case "$FIRMWARE" in
"ath9k-eeprom-ahb-18100000.wmac.bin")
case $board in
+ netgear,wndr4300)
+ caldata_extract "caldata" 0x1000 0x440
+ ;;
zyxel,nbg6716)
caldata_extract "art" 0x1000 0x440
ath9k_patch_mac $(mtd_get_mac_ascii u-boot-env ethaddr)
@@ -18,4 +21,14 @@ case "$FIRMWARE" in
;;
esac
;;
+"ath9k-eeprom-pci-0000:00:00.0.bin")
+ case $board in
+ netgear,wndr4300)
+ caldata_extract "caldata" 0x5000 0x440
+ ;;
+ *)
+ caldata_die "board $board is not supported yet"
+ ;;
+ esac
+ ;;
esac
diff --git a/target/linux/ath79/nand/base-files/lib/upgrade/platform.sh b/target/linux/ath79/nand/base-files/lib/upgrade/platform.sh
index 6f8c7d47ff..1b1ae0391e 100644
--- a/target/linux/ath79/nand/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ath79/nand/base-files/lib/upgrade/platform.sh
@@ -14,6 +14,7 @@ platform_do_upgrade() {
case "$board" in
aerohive,hiveap-121|\
+ netgear,wndr4300|\
zyxel,nbg6716)
nand_do_upgrade "$1"
;;