aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-21 20:37:55 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-27 21:31:20 +0100
commit9b5e9b65cfad4af514411ace3526a663c2dad890 (patch)
tree54a452935b2b4bc933d00e8d32f2912aa1126616 /target
parentddc75ff70416459127afec167f949e5d3db06d7a (diff)
downloadupstream-9b5e9b65cfad4af514411ace3526a663c2dad890.tar.gz
upstream-9b5e9b65cfad4af514411ace3526a663c2dad890.tar.bz2
upstream-9b5e9b65cfad4af514411ace3526a663c2dad890.zip
ath79: remove generic profiles
On a platform with many very different devices, like found on ath79, the generic profiles seem like remnants of the past that do not have a real use anymore. Remove them to have one thing less to maintain. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Acked-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/generic/profiles/00-default.mk16
-rw-r--r--target/linux/ath79/mikrotik/profiles/00-default.mk18
-rw-r--r--target/linux/ath79/nand/profiles/00-default.mk18
-rw-r--r--target/linux/ath79/tiny/profiles/00-default.mk9
4 files changed, 0 insertions, 61 deletions
diff --git a/target/linux/ath79/generic/profiles/00-default.mk b/target/linux/ath79/generic/profiles/00-default.mk
deleted file mode 100644
index 83b39e4418..0000000000
--- a/target/linux/ath79/generic/profiles/00-default.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
- NAME:=Default Profile (all drivers)
- PRIORITY := 1
-endef
-
-define Profile/Default/Description
- Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ath79/mikrotik/profiles/00-default.mk b/target/linux/ath79/mikrotik/profiles/00-default.mk
deleted file mode 100644
index 14712da593..0000000000
--- a/target/linux/ath79/mikrotik/profiles/00-default.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2020 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
- NAME:=Default Profile (all drivers)
- PACKAGES:= \
- kmod-usb-ohci kmod-usb2 nand-utils
- PRIORITY := 1
-endef
-
-define Profile/Default/Description
- Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ath79/nand/profiles/00-default.mk b/target/linux/ath79/nand/profiles/00-default.mk
deleted file mode 100644
index 6e618113a5..0000000000
--- a/target/linux/ath79/nand/profiles/00-default.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
- NAME:=Default Profile
- PACKAGES:= \
- kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
- PRIORITY := 1
-endef
-
-define Profile/Default/Description
- Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ath79/tiny/profiles/00-default.mk b/target/linux/ath79/tiny/profiles/00-default.mk
deleted file mode 100644
index aa8e1195f8..0000000000
--- a/target/linux/ath79/tiny/profiles/00-default.mk
+++ /dev/null
@@ -1,9 +0,0 @@
-define Profile/Default
- NAME:=Default Profile (all drivers)
- PRIORITY := 1
-endef
-
-define Profile/Default/Description
- Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))