aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorThibaut VARENE <hacks@slashdirt.org>2017-07-28 13:00:54 +0200
committerMathias Kresin <dev@kresin.me>2017-09-09 09:55:26 +0200
commit991681cf4946b493048c8ea1cb6227d961b2024d (patch)
tree766b0005b45106986f9bf30030d433fdf9959dcb /target
parent66a8c8f04c7ab341aaa65e18c3af276fa70d5b56 (diff)
downloadupstream-991681cf4946b493048c8ea1cb6227d961b2024d.tar.gz
upstream-991681cf4946b493048c8ea1cb6227d961b2024d.tar.bz2
upstream-991681cf4946b493048c8ea1cb6227d961b2024d.zip
ramips: Archer C50v1: support US and EU versions
For the Archer C50v1, the EU and US versions are differentiated by their respective HW additional version (0x0 for US, 0x2 for EU). The stock web interface checks this field before flashing, making it impossible to flash the current (US) factory image on EU hardware. However the bootloader does not check this field, making it possible to use a single sysupgrade image for both hardware. This patch adds the necessary build bits to generate both EU and US factory images, and renames the target as "Archer C50v1" since there are as of now 3 different versions of Archer C50 (all with different CPUs). Signed-off-by: Thibaut VARENE <hacks@slashdirt.org>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/mt7620.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index b0eb337a47..f201c9d404 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -42,15 +42,17 @@ define Device/ArcherC20i
endef
TARGET_DEVICES += ArcherC20i
-define Device/ArcherC50
+define Device/ArcherC50v1
$(Device/Archer)
DTS := ArcherC50
SUPPORTED_DEVICES := c50
TPLINK_BOARD_ID := ArcherC50
- IMAGES += factory.bin
- DEVICE_TITLE := TP-Link ArcherC50
+ IMAGES += factory-us.bin factory-eu.bin
+ IMAGE/factory-us.bin := tplink-v2-image -w 0
+ IMAGE/factory-eu.bin := tplink-v2-image -w 2
+ DEVICE_TITLE := TP-Link ArcherC50v1
endef
-TARGET_DEVICES += ArcherC50
+TARGET_DEVICES += ArcherC50v1
define Device/ArcherMR200
$(Device/Archer)