aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-03-06 18:59:16 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-03-06 19:05:53 +0000
commit969083634481c3ab5fb80509f385ef10ab45b55f (patch)
treeaea58815d90a79ba87247dfd32687c657934313c /target
parent8dd0215676a304456d25ff3ac4542c7303831a90 (diff)
downloadupstream-969083634481c3ab5fb80509f385ef10ab45b55f.tar.gz
upstream-969083634481c3ab5fb80509f385ef10ab45b55f.tar.bz2
upstream-969083634481c3ab5fb80509f385ef10ab45b55f.zip
ipq40xx: work-around borked QCA SDK bootloader
The bootloader of many ipq40xx boards seems to require the config node of the FIT image to be 'config@1' (or a secific different value). This requirement used to be implicitely satisfied because OpenWrt used to also call the configuration node inside a FIT image 'config@1'. However, as recent U-Boot now prohibits the use of the '@' symbol as part of node names, this was changed by commit 5ec60cbe9d ("scripts: mkits.sh: replace @ with - in nodes") Explicitely restore the default name of the configuration node to 'config@1' on ipq40xx. Reported-by: Chen Minqiang <ptpt52@gmail.com> Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ipq40xx/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index a7710cfe05..5851b29875 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -6,6 +6,7 @@ define Device/Default
KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
KERNEL_LOADADDR := 0x80208000
DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
+ DEVICE_DTS_CONFIG := config@1
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin = sysupgrade-tar | append-metadata
IMAGE/sysupgrade.bin/squashfs :=