aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-03-01 08:14:38 +0000
committerJohn Crispin <blogic@openwrt.org>2016-03-01 08:14:38 +0000
commit940bd5adbc46115bb054fe82ae0bbe10b9b837ee (patch)
tree3ab7ce7c8019c73d57b80b295536872742f6d07d /target
parente8e35f5e43ef5a7af0bbb330f851cb4bacc08382 (diff)
downloadupstream-940bd5adbc46115bb054fe82ae0bbe10b9b837ee.tar.gz
upstream-940bd5adbc46115bb054fe82ae0bbe10b9b837ee.tar.bz2
upstream-940bd5adbc46115bb054fe82ae0bbe10b9b837ee.zip
sunxi: respect CONFIG_TARGET_IMAGES_GZIP
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> Backport of r46608 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48836 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/sunxi/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index 19ab935f3b..d3f440941d 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -43,6 +43,10 @@ define Image/Build/SDCard
$(CONFIG_SUNXI_SD_BOOT_PARTSIZE) \
$(CONFIG_TARGET_ROOTFS_PARTSIZE) \
$(KDIR)/uboot-sunxi-$(PROFILE)-u-boot-with-spl.bin
+
+ ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
+ gzip -f9n $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-sdcard-vfat-$(1).img
+ endif
endef
define Image/Build/Profile/A10-OLinuXino-Lime