aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-02-15 20:03:18 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-02-15 20:03:18 +0000
commit900de421864beceaf7a17142dd1f1f56caadafb2 (patch)
tree5ba66564e7ed87e05bae86d2d7100dbafd7fc49d /target
parent1d1e4d10354832fbb2884d55464fc3f3ddbe2390 (diff)
downloadupstream-900de421864beceaf7a17142dd1f1f56caadafb2.tar.gz
upstream-900de421864beceaf7a17142dd1f1f56caadafb2.tar.bz2
upstream-900de421864beceaf7a17142dd1f1f56caadafb2.zip
Add audio feature flag.
There are targets which neither have usb host nor pci support but do have audio capabilities. Those targets should expliclitly specifiy that they support audio through the new feature flag. The audio feature flag is also implicitly selected by the usb and pci feature flags. SVN-Revision: 19643
Diffstat (limited to 'target')
-rw-r--r--target/Config.in5
-rw-r--r--target/linux/uml/Makefile2
-rw-r--r--target/linux/xburst/Makefile4
3 files changed, 8 insertions, 3 deletions
diff --git a/target/Config.in b/target/Config.in
index f5aa043053..f881245c62 100644
--- a/target/Config.in
+++ b/target/Config.in
@@ -11,6 +11,9 @@ config LINUX_2_6
config HAS_FPU
bool
+config AUDIO_SUPPORT
+ bool
+
config DISPLAY_SUPPORT
bool
@@ -18,6 +21,7 @@ config GPIO_SUPPORT
bool
config PCI_SUPPORT
+ select AUDIO_SUPPORT
bool
config PCIE_SUPPORT
@@ -27,6 +31,7 @@ config PCMCIA_SUPPORT
bool
config USB_SUPPORT
+ select AUDIO_SUPPORT
bool
config BIG_ENDIAN
diff --git a/target/linux/uml/Makefile b/target/linux/uml/Makefile
index 5f3181fce2..f2d9ce4525 100644
--- a/target/linux/uml/Makefile
+++ b/target/linux/uml/Makefile
@@ -20,7 +20,7 @@ ARCH:=$(shell uname -m | sed \
)
BOARD:=uml
BOARDNAME:=User Mode Linux
-FEATURES:=ext2
+FEATURES:=ext2 audio
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
LINUX_VERSION:=2.6.30.10
diff --git a/target/linux/xburst/Makefile b/target/linux/xburst/Makefile
index 7707c76045..7fdb93ce17 100644
--- a/target/linux/xburst/Makefile
+++ b/target/linux/xburst/Makefile
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
ARCH:=mipsel
BOARD:=xburst
BOARDNAME:=XBurst JZ47x0
-FEATURES:=jffs2 tgz ubifs
+FEATURES:=jffs2 tgz ubifs audio
-LINUX_VERSION:=2.6.32.8
+LINUX_VERSION:=2.6.32.7
DEVICE_TYPE=other