aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorChris Blake <chrisrblake93@gmail.com>2017-03-31 04:32:55 -0500
committerFelix Fietkau <nbd@nbd.name>2017-04-26 11:34:17 +0200
commit8f43ba8c489caa978b368decf0d66f70374389fd (patch)
tree7964f6d56d269307d20d96959b22f261067fa3b3 /target
parentd1c3a9485a90fff9bf7083faba4138e14dcdae7d (diff)
downloadupstream-8f43ba8c489caa978b368decf0d66f70374389fd.tar.gz
upstream-8f43ba8c489caa978b368decf0d66f70374389fd.tar.bz2
upstream-8f43ba8c489caa978b368decf0d66f70374389fd.zip
apm821xx: Merge the Cisco Meraki MX60 & MX60W
Both of these boards share the same DTS, and hardware. The only difference would be the PCI-E slot, and ath9k card found on the MX60W. Due to the similarities, it would be more efficient to merge these profiles. Signed-off-by: Chris Blake <chrisrblake93@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/apm821xx/image/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 1dae2b6636..6ed183c376 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -88,7 +88,7 @@ endef
TARGET_DEVICES += mr24
define Device/mx60
- DEVICE_TITLE := Cisco Meraki MX60
+ DEVICE_TITLE := Cisco Meraki MX60/MX60W
DEVICE_PACKAGES := kmod-spi-gpio kmod-usb-ledtrig-usbport kmod-usb-dwc2 \
kmod-usb-storage block-mount
DEVICE_PROFILE := MX60
@@ -112,12 +112,6 @@ define Device/mx60
endef
TARGET_DEVICES += mx60
-define Device/mx60w
-$(Device/mx60)
- DEVICE_TITLE := Cisco Meraki MX60W
-endef
-TARGET_DEVICES += mx60w
-
define Build/create-uImage-dtb
# flat_dt target expect FIT image - which WNDR4700's uboot doesn't support
-$(STAGING_DIR_HOST)/bin/mkimage -A $(LINUX_KARCH) \