aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2018-03-22 21:47:17 +0100
committerMathias Kresin <dev@kresin.me>2018-04-04 08:42:46 +0200
commit8db84cc0ee70382ea7f861691f73252cc7d3dfb3 (patch)
treed491a1035bb41228b32fae30366bab67a6f1a31e /target
parent6525bffc0a7ee6fabfe331a4d9e3eeabdd3516ae (diff)
downloadupstream-8db84cc0ee70382ea7f861691f73252cc7d3dfb3.tar.gz
upstream-8db84cc0ee70382ea7f861691f73252cc7d3dfb3.tar.bz2
upstream-8db84cc0ee70382ea7f861691f73252cc7d3dfb3.zip
ramips: add support for DLINK DWR-921-C3
The DWR-921-C3 Wireless Routers with LTE embedded modem is based on the MT7620N SoC. Specification: * MediaTek MT7620N (580 Mhz) * 64 MB of RAM * 16 MB of FLASH * 802.11bgn radio * 5x 10/100 Mbps Ethernet (1 WAN and 4 LAN) * 2x external, detachable (LTE) antennas * UART header on PCB (57600 8n1) * 6x LED (GPIO-controlled) * 1x bi-color Signal Strength LED (GPIO-controlled) * 2x button * JBOOT bootloader Installation: Apply factory image via d-link http web-gui. How to revert to OEM firmware: 1.) Push the reset button and turn on the power. Wait until LED start blinking (~10sec.) 2.) Upload original factory image via JBOOT http (IP: 192.168.123.254) 3.) If http doesn't work, it can be done with curl command: curl -F FN=@XXXXX.bin http://192.168.123.254/upg where XXXXX.bin is name of firmware file. Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/mt7620.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 185a081c90..75cd8184e2 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -178,6 +178,14 @@ define Device/dlink_dwr-921-c1
endef
TARGET_DEVICES += dlink_dwr-921-c1
+define Device/dlink_dwr-921-c3
+ $(Device/dlink_dwr-921-c1)
+ DEVICE_TITLE := D-Link DWR-921 C3
+ DLINK_ROM_ID := DLK6E2414009
+ SUPPORTED_DEVICES := dlink,dwr-921-c1
+endef
+TARGET_DEVICES += dlink_dwr-921-c3
+
define Device/e1700
DTS := E1700
IMAGES += factory.bin