aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorBirger Koblitz <mail@birger-koblitz.de>2021-01-05 20:40:52 +0100
committerPetr Štetiar <ynezz@true.cz>2021-01-05 22:43:40 +0100
commit89f71ebb355c624320c2b0ace8ae9488ff53cbeb (patch)
tree8c3acb260b7b6e75cde102a06bf3d0d4322df9e1 /target
parentf34f4a6665a91571866de38f476554ed986eccf2 (diff)
downloadupstream-89f71ebb355c624320c2b0ace8ae9488ff53cbeb.tar.gz
upstream-89f71ebb355c624320c2b0ace8ae9488ff53cbeb.tar.bz2
upstream-89f71ebb355c624320c2b0ace8ae9488ff53cbeb.zip
realtek: fix build issues
This fixes the build problems for the REALTEK target by adding a proper configuration option for the phy module. Signed-off-by: Birger Koblitz <mail@birger-koblitz.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/realtek/config-5.41
-rw-r--r--target/linux/realtek/patches-5.4/705-add-rtl-phy.patch22
2 files changed, 19 insertions, 4 deletions
diff --git a/target/linux/realtek/config-5.4 b/target/linux/realtek/config-5.4
index 170bcb7632..2176a2cf50 100644
--- a/target/linux/realtek/config-5.4
+++ b/target/linux/realtek/config-5.4
@@ -71,6 +71,7 @@ CONFIG_GENERIC_TIME_VSYSCALL=y
CONFIG_GPIOLIB=y
CONFIG_GPIO_RTL8231=y
CONFIG_GPIO_RTL838X=y
+CONFIG_REALTEK_SOC_PHY=y
CONFIG_GRO_CELLS=y
CONFIG_HANDLE_DOMAIN_IRQ=y
CONFIG_HARDWARE_WATCHPOINTS=y
diff --git a/target/linux/realtek/patches-5.4/705-add-rtl-phy.patch b/target/linux/realtek/patches-5.4/705-add-rtl-phy.patch
index 826891abe1..ea0d48861d 100644
--- a/target/linux/realtek/patches-5.4/705-add-rtl-phy.patch
+++ b/target/linux/realtek/patches-5.4/705-add-rtl-phy.patch
@@ -1,11 +1,25 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -454,6 +454,12 @@
+ ---help---
+ Supports the Realtek 821x PHY.
+
++config REALTEK_SOC_PHY
++ tristate "Realtek SoC PHYs"
++ depends on RTL838X
++ ---help---
++ Supports the PHYs found in combination with Realtek Switch SoCs
++
+ config RENESAS_PHY
+ tristate "Driver for Renesas PHYs"
+ ---help---
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -101,7 +101,7 @@ obj-$(CONFIG_MICROSEMI_PHY) += mscc.o
- obj-$(CONFIG_NATIONAL_PHY) += national.o
+@@ -87,6 +87,7 @@
obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
obj-$(CONFIG_QSEMI_PHY) += qsemi.o
--obj-$(CONFIG_REALTEK_PHY) += realtek.o
-+obj-$(CONFIG_REALTEK_PHY) += realtek.o rtl83xx-phy.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
++obj-$(CONFIG_REALTEK_SOC_PHY) += rtl83xx-phy.o
obj-$(CONFIG_RENESAS_PHY) += uPD60620.o
obj-$(CONFIG_ROCKCHIP_PHY) += rockchip.o
obj-$(CONFIG_SMSC_PHY) += smsc.o