aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-08-09 23:45:56 +0200
committerDavid Bauer <mail@david-bauer.net>2019-08-10 00:48:01 +0200
commit891a7007598d5d396bf621fcc6ab0cc083b192b6 (patch)
treecb2e633dd48e658577bf57ab1ad6e2e9fc151002 /target
parentc12947b39e96c82974cbe0fc3557259713f37770 (diff)
downloadupstream-891a7007598d5d396bf621fcc6ab0cc083b192b6.tar.gz
upstream-891a7007598d5d396bf621fcc6ab0cc083b192b6.tar.bz2
upstream-891a7007598d5d396bf621fcc6ab0cc083b192b6.zip
lantiq: enable second VPE on Fritz!Box 7412
The AVM Fritz!Box 7412 does not use the VMMC part of the Lantiq chip but rather a proprietary solution based on the DECT chip for the FXS ports. Therefore, the second VPE can be enabled for use with OpenWrt. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target')
-rw-r--r--target/linux/lantiq/files/arch/mips/boot/dts/FRITZ7412.dts2
-rw-r--r--target/linux/lantiq/image/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/lantiq/files/arch/mips/boot/dts/FRITZ7412.dts b/target/linux/lantiq/files/arch/mips/boot/dts/FRITZ7412.dts
index 97817595e9..111ef1b320 100644
--- a/target/linux/lantiq/files/arch/mips/boot/dts/FRITZ7412.dts
+++ b/target/linux/lantiq/files/arch/mips/boot/dts/FRITZ7412.dts
@@ -11,7 +11,7 @@
model = "AVM FRITZ!Box 7412";
chosen {
- bootargs = "console=ttyLTQ0,115200 mem=126M vpe1_load_addr=0x87e00000 vpe1_mem=2M maxvpes=1 maxtcs=1 nosmp";
+ bootargs = "console=ttyLTQ0,115200";
};
aliases {
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 2352cb6b5e..f71a262c82 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -673,7 +673,7 @@ define Device/avm_fritz7412
KERNEL_SIZE := 4096k
IMAGE_SIZE := 49152k
DEVICE_TITLE := AVM FRITZ!Box 7412
- DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-basic kmod-ltq-tapi kmod-ltq-vmmc fritz-tffs-nand fritz-caldata
+ DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-basic fritz-tffs-nand fritz-caldata
endef
TARGET_DEVICES += avm_fritz7412