aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-01 11:04:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-01 11:04:08 +0000
commit8509d0542f3984fc703b5829c17c0f1c0c264fe7 (patch)
tree0bd52ebde684a0f22bd19ba03719187df6d1e94d /target
parent5719247ae3fc89e58594a0fb4c5dcf4575782d5a (diff)
downloadupstream-8509d0542f3984fc703b5829c17c0f1c0c264fe7.tar.gz
upstream-8509d0542f3984fc703b5829c17c0f1c0c264fe7.tar.bz2
upstream-8509d0542f3984fc703b5829c17c0f1c0c264fe7.zip
add a gzipped uImage for ar71xx
SVN-Revision: 12453
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 4d86889a5e..67764d647c 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -13,6 +13,11 @@ define Image/BuildKernel
$(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma bs=65536 conv=sync
dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.gz bs=65536 conv=sync
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma
+ mkimage -A mips -O linux -T kernel -a 0x80060000 -C gzip -e \
+ 0x80060000 \
+ -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/vmlinux.bin.gz $(BIN_DIR)/openwrt-$(BOARD)-uImage.gz
endef
define Image/Build/squashfs