aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2023-07-04 20:42:22 +0200
committerChristian Lamparter <chunkeey@gmail.com>2023-07-04 22:11:53 +0200
commit80a6b0a9173a1182081e184fd0f22c0996bd16b2 (patch)
tree13b2a5841c2ea2195cf7fe92bd034fb54d000e9b /target
parentfbc23f664d85b396e9fbee1d5977d70bc4987d87 (diff)
downloadupstream-80a6b0a9173a1182081e184fd0f22c0996bd16b2.tar.gz
upstream-80a6b0a9173a1182081e184fd0f22c0996bd16b2.tar.bz2
upstream-80a6b0a9173a1182081e184fd0f22c0996bd16b2.zip
ipq-wifi: fix upstream board-2.bin ZTE M289F snafu
The upstream board-2.bin file in the linux-firmware.git repository for the QCA4019 contains a packed board-2.bin for this device for both 2.4G and 5G wifis. This isn't something that the ath10k driver supports. Until this feature either gets implemented - which is very unlikely -, or the upstream boardfile is mended (both, the original submitter and ath10k-firmware custodian have been notified). OpenWrt will go back and use its own bespoke boardfile. This unfortunately means that 2.4G and on some revisions the 5G WiFi is not available in the initramfs image for this device. qca9984 isn't affected. Fixes: #12886 Reported-by: Christian Heuff <christian@heuff.at> Debugged-by: Georgios Kourachanis <geo.kourachanis@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> (cherry picked from commit 75505c5ec724b9b961dcb411bac1d4b9aede3e1d)
Diffstat (limited to 'target')
-rw-r--r--target/linux/ipq40xx/image/generic.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 9dfa877c32..b8e3edf857 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -1003,7 +1003,7 @@ TARGET_DEVICES += zte_mf286d
define Device/zte_mf289f
$(call Device/zte_mf28x_common)
DEVICE_MODEL := MF289F
- DEVICE_PACKAGES += ath10k-firmware-qca9984-ct
+ DEVICE_PACKAGES += ipq-wifi-zte_mf289f ath10k-firmware-qca9984-ct
endef
TARGET_DEVICES += zte_mf289f