aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-04 17:30:59 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-04 17:30:59 +0000
commit807e0461935a8e404d527557561d3b80a1a4b279 (patch)
tree9814ca01f0a638c89906626a011fa9cc8a114836 /target
parent923f3e37529eb40e2fb1a6a00c3306e116440395 (diff)
downloadupstream-807e0461935a8e404d527557561d3b80a1a4b279.tar.gz
upstream-807e0461935a8e404d527557561d3b80a1a4b279.tar.bz2
upstream-807e0461935a8e404d527557561d3b80a1a4b279.zip
ar71xx: specify console kernel parameter for the Compex boards
SVN-Revision: 29660
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 78bf7e39c7..4e143ddc0e 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -258,10 +258,11 @@ endef
define Image/Build/MyLoader
- -$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s $(3) \
- -p0x030000:0xe0000:al:0x80060000:kernel:$(KDIR)/vmlinux.bin.lzma \
+ $(call PatchKernelLzma,$(2),$(3))
+ -$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s $(4) \
+ -p0x030000:0xe0000:al:0x80060000:kernel:$(KDIR)/vmlinux-$(2).bin.lzma \
-p0x110000:0:::rootfs:$(KDIR)/root.$(1) \
- $(call imgname,$(1),$(2))-$(4)-factory.img
+ $(call imgname,$(1),$(2))-$(5)-factory.img
endef
ubntxm_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1024k(kernel),6528k(rootfs),256k(cfg)ro,64k(EEPROM)ro,7552k@0x50000(firmware)
@@ -637,11 +638,12 @@ define Image/Build/Profile/PB92
$(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,pb92,$(pb92_cmdline),,917504,2818048,KR)
endef
+wp543_cmdline=console=ttyS0,115200
define Image/Build/Profile/WP543
- $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wp543,0x200000,2M)
- $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wp543,0x400000,4M)
- $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wp543,0x800000,8M)
- $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wp543,0x1000000,16M)
+ $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wp543,$(wp543_cmdline),0x200000,2M)
+ $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wp543,$(wp543_cmdline),0x400000,4M)
+ $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wp543,$(wp543_cmdline),0x800000,8M)
+ $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wp543,$(wp543_cmdline),0x1000000,16M)
endef
dir600a1_cmdline=board=DIR-600-A1 console=ttyS0,115200