aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-08-05 10:31:52 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-08-05 10:31:52 +0000
commit7e5a1bc1d00b23fdf2f2cc806c7701bbef28356e (patch)
tree00a373801ffa8594b347f7be8a5f957d5926dd84 /target
parent77966b81d873fb54709e7ba457173dad86b95f5e (diff)
downloadupstream-7e5a1bc1d00b23fdf2f2cc806c7701bbef28356e.tar.gz
upstream-7e5a1bc1d00b23fdf2f2cc806c7701bbef28356e.tar.bz2
upstream-7e5a1bc1d00b23fdf2f2cc806c7701bbef28356e.zip
ar71xx: fix image generation
SVN-Revision: 27907
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 7f68ee5971..569f2bd12d 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -60,12 +60,12 @@ endef
define MkuImageLzma
$(call PatchKernelLzma,$(1),$(2))
- $(call MkImage,lzma,$(KDIR)/vmlinux-$(1).bin.lzma,$(KDIR)/vmlinux-$(1).uImage)
+ $(call MkuImage,lzma,$(KDIR)/vmlinux-$(1).bin.lzma,$(KDIR)/vmlinux-$(1).uImage)
endef
define MkuImageGzip
$(call PatchKernelGzip,$(1),$(2))
- $(call MkImage,gzip,$(KDIR)/vmlinux-$(1).bin.gz,$(KDIR)/vmlinux-$(1).uImage)
+ $(call MkuImage,gzip,$(KDIR)/vmlinux-$(1).bin.gz,$(KDIR)/vmlinux-$(1).uImage)
endef
define CatFiles
@@ -218,10 +218,10 @@ ubntxm_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1024k(kernel),
define Image/Build/UBNTXM
$(call MkuImageLzma,$(2),$(3) $(ubntxm_mtdlayout))
$(call Sysupgrade/KR,$(1),$(2),1048576,6684672)
- dd if=$(KDIR)/vmlinux-$(2).uImage.bin of=$(KDIR)/vmlinux-$(2).uImage bs=1024k conv=sync
+ dd if=$(KDIR)/vmlinux-$(2).uImage of=$(KDIR)/vmlinux-$(2).uImage.bin bs=1024k conv=sync
-$(STAGING_DIR_HOST)/bin/mkfwimage \
-B $(4) -v $(5).$(6).OpenWrt.$(REVISION) \
- -k $(KDIR)/vmlinux-$(2).uImage \
+ -k $(KDIR)/vmlinux-$(2).uImage.bin \
-r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
-o $(call factoryname,$(1),$(2))
endef
@@ -352,7 +352,7 @@ define Image/Build/Zcomax
if [ -e "$(call sysupname,$(1),$(2))" ]; then \
$(STAGING_DIR_HOST)/bin/mkzcfw \
-B $(2) \
- -k $(KDIR)/vmlinux-$(2).uImage.bin \
+ -k $(KDIR)/vmlinux-$(2).uImage \
-r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
-o $(call imgname,$(1),$(2))-factory.img; \
fi