aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tmn505@gmail.com>2023-08-16 20:28:01 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-11-19 14:58:44 +0100
commit7901fec6b8faf56b59e123437146f73819a95034 (patch)
tree9b3254d69c32e46687f52cc59bcfa49c9c765e7a /target
parent7dabd7a206856d9a77fadc15b08ed0c04d995767 (diff)
downloadupstream-7901fec6b8faf56b59e123437146f73819a95034.tar.gz
upstream-7901fec6b8faf56b59e123437146f73819a95034.tar.bz2
upstream-7901fec6b8faf56b59e123437146f73819a95034.zip
ath79: image: allow changing kernel option in mkubntimage
Backport didn't include changes to mkubntimage invocation, which allowed to pass arguments. This in result produces broken routerstation factory images, which have kernel embedded as kernel partition instead of LZMA loader. Fixes: #13260 Fixes: 8e09f9ffc3cc ("ath79: switch some RedBoot based devices to OKLI loader") Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/image/common-ubnt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath79/image/common-ubnt.mk b/target/linux/ath79/image/common-ubnt.mk
index 625f0b4f3f..76d6de000b 100644
--- a/target/linux/ath79/image/common-ubnt.mk
+++ b/target/linux/ath79/image/common-ubnt.mk
@@ -10,7 +10,7 @@ UBNT_REVISION := $(VERSION_DIST)-$(REVISION)
define Build/mkubntimage
-$(STAGING_DIR_HOST)/bin/mkfwimage -B $(UBNT_BOARD) \
-v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-$(VERSION_DIST)-$(REVISION) \
- -k $(IMAGE_KERNEL) -r $@ -o $@
+ -k $(if $(1),$(1),$(IMAGE_KERNEL)) -r $@ -o $@
endef
define Build/mkubntimage2