aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-07-31 11:42:17 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-07-31 11:42:17 +0000
commit781c091ea5d8e373d247dbe6c667360c8a0f7345 (patch)
tree5d4e01e70784bf6e4d2264ffc14ba49a3f1c67d9 /target
parent3aca383c7230d72b8f8570ee9207b87ef48fcf20 (diff)
downloadupstream-781c091ea5d8e373d247dbe6c667360c8a0f7345.tar.gz
upstream-781c091ea5d8e373d247dbe6c667360c8a0f7345.tar.bz2
upstream-781c091ea5d8e373d247dbe6c667360c8a0f7345.zip
fix jffs2 64k and 128k images overwrite each other
When trying to build images with jffs2 filesystem for ramips platform there is only one jffs2 image produced instead of two (64k and 128k). Signed-off-by: Roman Yeryomin <roman@advem.lv> SVN-Revision: 22435
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index d52c41f0b8..1addcbf22f 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define imgname
-$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(patsubst jffs2-%,jffs2,$(patsubst squashfs-%,squashfs,$(1)))
+$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1)
endef
VMLINUX:=$(IMG_PREFIX)-vmlinux