aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-08-30 10:51:09 +0200
committerJo-Philipp Wich <jo@mein.io>2018-08-30 10:57:35 +0200
commit77e2bccde8f7f98603f60473023dadec4f473cf6 (patch)
tree5aae305d1e9ccdb1f4de9519f7b2c8dd34fabfe8 /target
parenta6e11ccb136fd87efd2757a2959b8d9510534501 (diff)
downloadupstream-77e2bccde8f7f98603f60473023dadec4f473cf6.tar.gz
upstream-77e2bccde8f7f98603f60473023dadec4f473cf6.tar.bz2
upstream-77e2bccde8f7f98603f60473023dadec4f473cf6.zip
ramips: only limit lzma dictionary size on mt7621
The changed dictionary size leads to a different LZMA header which breaks sysupgrade image magic checkibng on at least some RT288x boards. Since the commit message only mentions testing on MT7621 and since the change appears to break at least one other ramips subtarget, do not take any chances and restrict the size limitation to only MT7621. Fixes FS#1797 Fixes 09b6755946 ("ramips: limit dictionary size for lzma compression") Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/Makefile2
-rw-r--r--target/linux/ramips/image/mt7621.mk1
2 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 5426226795..9cf64361a4 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -31,7 +31,7 @@ loadaddr-$(CONFIG_TARGET_ramips_mt7621) := 0x80001000
KERNEL_LOADADDR := $(loadaddr-y)
-KERNEL_DTB = kernel-bin | patch-dtb | lzma -d21
+KERNEL_DTB = kernel-bin | patch-dtb | lzma
define Device/Default
PROFILES = Default $$(DTS)
KERNEL_DEPENDS = $$(wildcard ../dts/$$(DTS).dts)
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 4195c22691..a4a0f3d293 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2,6 +2,7 @@
# MT7621 Profiles
#
+KERNEL_DTB += -d21
DEVICE_VARS += TPLINK_BOARD_ID TPLINK_HEADER_VERSION TPLINK_HWID TPLINK_HWREV
define Build/elecom-gst-factory