aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-03 08:28:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-03 08:28:05 +0000
commit773d1fc4f663a3c108242b94ce94f595a1576233 (patch)
tree8960842e2978aae5cd21a6551b896b4b680cbf36 /target
parent84c301cf9a4e88d1c6634ff0786eed86f397c5db (diff)
downloadupstream-773d1fc4f663a3c108242b94ce94f595a1576233.tar.gz
upstream-773d1fc4f663a3c108242b94ce94f595a1576233.tar.bz2
upstream-773d1fc4f663a3c108242b94ce94f595a1576233.zip
implement quilt handling for the kernel tree ... and there was much rejoicing!
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7474 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/Makefile2
-rw-r--r--target/linux/Makefile3
2 files changed, 4 insertions, 1 deletions
diff --git a/target/Makefile b/target/Makefile
index 9a7dff2a78..438d268b5e 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -51,5 +51,5 @@ image_install: image_compile
imagebuilder_install: image_install
$(MAKE) -C imagebuilder install
-%-prereq %-prepare %-download %-clean %-compile %-install: FORCE
+%-prereq %-prepare %-download %-clean %-compile %-install %-refresh: FORCE
$(MAKE) -C $* $(patsubst $*-%,%,$@)
diff --git a/target/linux/Makefile b/target/linux/Makefile
index c15d81999f..275085448f 100644
--- a/target/linux/Makefile
+++ b/target/linux/Makefile
@@ -19,6 +19,9 @@ compile:
install:
$(MAKE) -C $(BOARD)-$(KERNEL) install
+refresh:
+ $(MAKE) -C $(BOARD)-$(KERNEL) refresh
+
menuconfig:
$(MAKE) -C $(BOARD)-$(KERNEL) menuconfig