aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorSven Eckelmann <sven@narfation.org>2020-11-23 13:41:34 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-12-29 00:03:26 +0100
commit75900a25ed2acd4201bcd9a5516bdf7cdb9a8e73 (patch)
treed7e189d3ceca7af2158fe064bd4ec9ed69a60937 /target
parentf096accce26bc46831e859ccd40b3f88e404cc7e (diff)
downloadupstream-75900a25ed2acd4201bcd9a5516bdf7cdb9a8e73.tar.gz
upstream-75900a25ed2acd4201bcd9a5516bdf7cdb9a8e73.tar.bz2
upstream-75900a25ed2acd4201bcd9a5516bdf7cdb9a8e73.zip
ath79: add support for OpenMesh OM2P-HS v3
Device specifications: ====================== * Qualcomm/Atheros AR9341 rev 1 * 535/400/200 MHz (CPU/DDR/AHB) * 64 MB of RAM * 16 MB of SPI NOR flash - 2x 7 MB available; but one of the 7 MB regions is the recovery image * 2x 10/100 Mbps Ethernet * 2T2R 2.4 GHz Wi-Fi * 6x GPIO-LEDs (3x wifi, 2x ethernet, 1x power) * 1x GPIO-button (reset) * external h/w watchdog (enabled by default) * TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX) * 2x fast ethernet - eth0 + 802.3af POE + builtin switch port 1 + used as LAN interface - eth1 + 18-24V passive POE (mode B) + used as WAN interface * 12-24V 1A DC * internal antennas Flashing instructions: ====================== Various methods can be used to install the actual image on the flash. Two easy ones are: ap51-flash ---------- The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be used to transfer the image to the u-boot when the device boots up. initramfs from TFTP ------------------- The serial console must be used to access the u-boot shell during bootup. It can then be used to first boot up the initramfs image from a TFTP server (here with the IP 192.168.1.21): setenv serverip 192.168.1.21 setenv ipaddr 192.168.1.1 tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr The actual sysupgrade image can then be transferred (on the LAN port) to the device via scp <filename-of-squashfs-sysupgrade>.bin root@192.168.1.1:/tmp/ On the device, the sysupgrade must then be started using sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin Signed-off-by: Sven Eckelmann <sven@narfation.org>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/dts/ar9341_openmesh_om2p-hs-v3.dts8
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/01_leds1
-rw-r--r--target/linux/ath79/generic/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ath79/image/generic.mk9
4 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/ar9341_openmesh_om2p-hs-v3.dts b/target/linux/ath79/dts/ar9341_openmesh_om2p-hs-v3.dts
new file mode 100644
index 0000000000..e3b15b17f6
--- /dev/null
+++ b/target/linux/ath79/dts/ar9341_openmesh_om2p-hs-v3.dts
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9341_openmesh_om2p-hs.dtsi"
+
+/ {
+ compatible = "openmesh,om2p-hs-v3", "qca,ar9341";
+ model = "OpenMesh OM2P-HS v3";
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index 8926ffc0c8..3889969ee5 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -147,6 +147,7 @@ comfast,cf-e560ac)
comfast,cf-ew72|\
openmesh,om2p-hs-v1|\
openmesh,om2p-hs-v2|\
+openmesh,om2p-hs-v3|\
telco,t1)
ucidef_set_led_switch "lan" "LAN" "blue:lan" "switch0" "0x02"
ucidef_set_led_netdev "wan" "WAN" "blue:wan" "eth1"
diff --git a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
index 73c328173a..9ff36f1bf5 100644
--- a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
@@ -53,6 +53,7 @@ platform_do_upgrade() {
openmesh,om2p-v4|\
openmesh,om2p-hs-v1|\
openmesh,om2p-hs-v2|\
+ openmesh,om2p-hs-v3|\
openmesh,om2p-hs-v4)
PART_NAME="inactive"
platform_do_upgrade_openmesh "$1"
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 4e80ac8402..631cc2fd6a 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1595,6 +1595,15 @@ define Device/openmesh_om2p-hs-v2
endef
TARGET_DEVICES += openmesh_om2p-hs-v2
+define Device/openmesh_om2p-hs-v3
+ $(Device/openmesh_om2p-common)
+ SOC := ar9341
+ DEVICE_MODEL := OM2P-HS
+ DEVICE_VARIANT := v3
+ SUPPORTED_DEVICES += om2p-hsv3
+endef
+TARGET_DEVICES += openmesh_om2p-hs-v3
+
define Device/openmesh_om2p-hs-v4
$(Device/openmesh_om2p-common)
SOC := qca9533