aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGeoff Levand <geoffrey.levand@am.sony.com>2009-08-18 23:07:45 +0000
committerGeoff Levand <geoffrey.levand@am.sony.com>2009-08-18 23:07:45 +0000
commit75816814668ff6f42b7d540c0f954030cf482861 (patch)
tree522b2f8eaabc526eacdffbe5c4dea2be01745730 /target
parent8ee102eea1f917809bd0d180d8241511e031d922 (diff)
downloadupstream-75816814668ff6f42b7d540c0f954030cf482861.tar.gz
upstream-75816814668ff6f42b7d540c0f954030cf482861.tar.bz2
upstream-75816814668ff6f42b7d540c0f954030cf482861.zip
powerpc: Create a powerpc64 config feature
The config symbol TARGET_ps3 is used in the build files where special handling for the 64 bit PowerPC processors is needed. Introduce a new config feature powerpc64, and replace the use of TARGET_ps3 with powerpc64. Signed-off-by: Geoff Levand <geoffrey.levand@am.sony.com> SVN-Revision: 17306
Diffstat (limited to 'target')
-rw-r--r--target/Config.in3
-rw-r--r--target/linux/ps3/Makefile1
-rw-r--r--target/linux/ps3/petitboot/target.mk2
3 files changed, 5 insertions, 1 deletions
diff --git a/target/Config.in b/target/Config.in
index 8bfeb83b27..ffd81d3f6c 100644
--- a/target/Config.in
+++ b/target/Config.in
@@ -100,6 +100,9 @@ config powerpc
select BIG_ENDIAN
bool
+config powerpc64
+ bool
+
config sh3
bool
diff --git a/target/linux/ps3/Makefile b/target/linux/ps3/Makefile
index 64d8477199..b59e161582 100644
--- a/target/linux/ps3/Makefile
+++ b/target/linux/ps3/Makefile
@@ -11,6 +11,7 @@ BOARD:=ps3
BOARDNAME:=Sony PS3 Game Console
MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
SUBTARGETS=petitboot
+FEATURES+=powerpc64
LINUX_VERSION:=2.6.28.10
diff --git a/target/linux/ps3/petitboot/target.mk b/target/linux/ps3/petitboot/target.mk
index 04ec11bb3e..845c4316d3 100644
--- a/target/linux/ps3/petitboot/target.mk
+++ b/target/linux/ps3/petitboot/target.mk
@@ -1,5 +1,5 @@
BOARDNAME:=Petitboot
-FEATURES:=fpu ramdisk
+FEATURES+=fpu ramdisk
define Target/Description
Build Petitboot bootloader