aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-07-03 15:01:55 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-07-03 15:01:55 +0000
commit6f54df889af09536edb4e461c51149243dc9483a (patch)
treee874265321b8d9e38ac0e6ab1256b2d8b55da562 /target
parent575a5286c89bf5ca0d3f0c66b51aab8566ff8212 (diff)
downloadupstream-6f54df889af09536edb4e461c51149243dc9483a.tar.gz
upstream-6f54df889af09536edb4e461c51149243dc9483a.tar.bz2
upstream-6f54df889af09536edb4e461c51149243dc9483a.zip
ramips: check the size of the uImage in image generation
SVN-Revision: 27388
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 98dbdfb703..446bf7b354 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -54,15 +54,12 @@ endef
define BuildFirmware/Generic
$(call PatchKernelLzma,$(2),$(3) $($(4)))
- if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt $(5) ]; then \
- echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
+ $(call MkImage,lzma,"$(KDIR)/vmlinux-$(2).bin.lzma","$(KDIR)/vmlinux-$(2).uImage")
+ if [ `stat -c%s "$(KDIR)/vmlinux-$(2).uImage"` -gt $(5) ]; then \
+ echo "Warning: $(KDIR)/vmlinux-$(2).uImage is too big"; \
else if [ `stat -c%s $(KDIR)/root.$(1)` -gt $(6) ]; then \
echo "Warning: $(KDIR)/root.$(1) is too big"; \
else \
- mkimage -A mips -O linux -T kernel -C lzma \
- $(call kernel_entry) \
- -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
- -d $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/vmlinux-$(2).uImage; \
( \
dd if=$(KDIR)/vmlinux-$(2).uImage bs=$(5) conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \