aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-11-20 12:17:43 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-11-20 12:17:43 +0000
commit68b5aa2fdf3d8bf7269296c55905914a7d15a420 (patch)
treeb364dbc1254ab7fe9988888c170e3f02e22feebb /target
parent97867f8717abc2b02bbea8c1ef625fe68f05700b (diff)
downloadupstream-68b5aa2fdf3d8bf7269296c55905914a7d15a420.tar.gz
upstream-68b5aa2fdf3d8bf7269296c55905914a7d15a420.tar.bz2
upstream-68b5aa2fdf3d8bf7269296c55905914a7d15a420.zip
ar71xx/image: provide lzma compressed elf kernel image
This will be used on the RB4xx/RB7xx/RB2011 boards. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 34272
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index dbda865ec6..f4d66b97cc 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -192,6 +192,7 @@ define Image/BuildKernel
dd if=$(KDIR)/vmlinux.bin.gz of=$(VMLINUX).gz bs=65536 conv=sync
$(call MkuImage,gzip,,$(KDIR)/vmlinux.bin.gz,$(UIMAGE)-gzip.bin)
$(call MkuImage,lzma,,$(KDIR)/vmlinux.bin.lzma,$(UIMAGE)-lzma.bin)
+ cp $(KDIR)/loader-generic.elf $(VMLINUX)-lzma.elf
-mkdir -p $(KDIR_TMP)
$(call Image/Build/Initramfs)
endef
@@ -945,6 +946,7 @@ endef
define Image/Prepare
gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
$(call CompressLzma,$(KDIR)/vmlinux,$(KDIR)/vmlinux.bin.lzma)
+ $(call Image/BuildLoader,generic,elf)
$(call Image/Build/Profile/$(if $(CONFIG_IB),Default,$(PROFILE)),loader)
endef