aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2017-10-10 19:17:37 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2017-10-12 23:40:27 +0200
commit67c0c5978d5419c6dc5908c912ade316134c4f34 (patch)
treed687ad022f2b0f138b785c2a4bc43d5798426e3a /target
parent4f3ddcb0e9db60630daba0671f84a08d78198b81 (diff)
downloadupstream-67c0c5978d5419c6dc5908c912ade316134c4f34.tar.gz
upstream-67c0c5978d5419c6dc5908c912ade316134c4f34.tar.bz2
upstream-67c0c5978d5419c6dc5908c912ade316134c4f34.zip
layerscape: only support 64-bit for ls1088ardb/ls2088ardb
This is no requirement and plan to support 32-bit for ls1088ardb and ls2088ardb. Current 32-bit firmware for them couldn't work, so only keep 64-bit support for these two boards in menuconfig. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/layerscape/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/layerscape/image/Makefile b/target/linux/layerscape/image/Makefile
index 92206a364f..5577b16238 100644
--- a/target/linux/layerscape/image/Makefile
+++ b/target/linux/layerscape/image/Makefile
@@ -87,6 +87,7 @@ define Device/ls1012ardb
endef
TARGET_DEVICES += ls1012ardb
+ifeq ($(SUBTARGET),armv8_64b)
define Device/ls1088ardb
DEVICE_TITLE := ls1088ardb-$(SUBTARGET)
DEVICE_PACKAGES += rcw-layerscape-ls1088ardb uboot-layerscape-$(SUBTARGET)-ls1088ardb mc-binary-ls1088ardb
@@ -106,5 +107,6 @@ define Device/ls2088ardb
append-rootfs | pad-rootfs | check-size 51380225
endef
TARGET_DEVICES += ls2088ardb
+endif
$(eval $(call BuildImage))