aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2019-11-03 04:10:12 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2019-11-03 04:25:40 +0000
commit66ebca7103052ba851be2261a4452787959de9c2 (patch)
tree2ac7b8c43dedb14a40c76f3e64747fdeec5937ba /target
parente4af39d56395738d86daa4babb379ab605b4d277 (diff)
downloadupstream-66ebca7103052ba851be2261a4452787959de9c2.tar.gz
upstream-66ebca7103052ba851be2261a4452787959de9c2.tar.bz2
upstream-66ebca7103052ba851be2261a4452787959de9c2.zip
build: label kernel and rootfs ext4 volumes
UUID of ext4 volumes generated by make_ext4fs are determined by volume label and it will all be 57f8f4bc-abf4-655f-bf67-946fc0f9f25b when label is empty Labeling them does not make them unique but tools like block command from fstools have a better chance differentiating them Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/mvebu/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index b4b77b70b4..967a1e4ee1 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -38,7 +38,7 @@ define Build/boot-img-ext4
$(foreach dts,$(DEVICE_DTS), $(CP) $(KDIR)/image-$(dts).dtb $@.boot/$(dts).dtb;)
$(CP) $(IMAGE_KERNEL) $@.boot/$(KERNEL_NAME)
-$(CP) $@-boot.scr $@.boot/boot.scr
- make_ext4fs -J -l $(CONFIG_TARGET_KERNEL_PARTSIZE)M $@.bootimg $@.boot
+ make_ext4fs -J -L kernel -l $(CONFIG_TARGET_KERNEL_PARTSIZE)M $@.bootimg $@.boot
endef
define Build/sdcard-img