aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-02-13 16:36:23 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-02-13 16:36:23 +0000
commit5f10ec3c36f8cadf32838cbe5b7953c442bc998e (patch)
tree582e4c25b87469aab61602091825efb3ed946246 /target
parent54ca3eed5d3d0c9e97c8b27ac447e803f867e373 (diff)
downloadupstream-5f10ec3c36f8cadf32838cbe5b7953c442bc998e.tar.gz
upstream-5f10ec3c36f8cadf32838cbe5b7953c442bc998e.tar.bz2
upstream-5f10ec3c36f8cadf32838cbe5b7953c442bc998e.zip
ar71xx: fix switch-config for dir-825-c1
Signed-off-by: Alexander Stadler <sa.maillists@univie.ac.at> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35588
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/uci-defaults/02_network8
1 files changed, 1 insertions, 7 deletions
diff --git a/target/linux/ar71xx/base-files/etc/uci-defaults/02_network b/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
index df2d98bc4a..7d825d7a10 100755
--- a/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
+++ b/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
@@ -62,13 +62,6 @@ tew-673gru)
ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 5t"
;;
-dir-825-c1)
- ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
- ucidef_add_switch "switch0" "1" "1"
- ucidef_add_switch_vlan "switch0" "1" "0t 2 3 4 5"
- ucidef_add_switch_vlan "switch0" "2" "0t 1"
- ;;
-
nbg460n_550n_550nh)
ucidef_set_interfaces_lan_wan "eth0" "eth1"
ucidef_add_switch "switch0" "1" "1"
@@ -181,6 +174,7 @@ wzr-hp-g300nh)
ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 5t"
;;
+dir-825-c1|\
wndr4300)
ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
ucidef_add_switch "switch0" "1" "1"
ing.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */
#
# Copyright (C) 2010-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#

include $(TOPDIR)/rules.mk

PKG_NAME:=mm-macros
PKG_VERSION:=0.9.5

PKG_SOURCE_URL:=http://ftp.gnome.org/pub/GNOME/sources/mm-common/0.9
PKG_SOURCE:=mm-common-$(PKG_VERSION).tar.bz2
PKG_MD5SUM:=4a4dad67fc8d7e0c529f3a8c6ba4d8b2

HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/mm-common-$(PKG_VERSION)

include $(INCLUDE_DIR)/host-build.mk

define Host/Install
	$(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
	$(INSTALL_DATA) $(HOST_BUILD_DIR)/macros/*.m4 $(STAGING_DIR_HOST)/share/aclocal/
endef

define Host/Clean
	-$(MAKE) -C $(HOST_BUILD_DIR) uninstall
	$(call Host/Clean/Default)
endef

$(eval $(call HostBuild))