aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorSven Eckelmann <sven@narfation.org>2020-11-23 13:41:34 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-12-28 19:37:24 +0100
commit5b37b52e69884c6c843738cc45ed8a1deba0eba3 (patch)
tree678beea5f3fba61ca1b2674cddf66ca95a5c5a39 /target
parentdd1d95cb0357278900d09fae3ad20e9e0b2d569a (diff)
downloadupstream-5b37b52e69884c6c843738cc45ed8a1deba0eba3.tar.gz
upstream-5b37b52e69884c6c843738cc45ed8a1deba0eba3.tar.bz2
upstream-5b37b52e69884c6c843738cc45ed8a1deba0eba3.zip
ath79: Add support for OpenMesh OM2P-HS v4
Device specifications: ====================== * Qualcomm/Atheros QCA9533 v2 * 650/600/217 MHz (CPU/DDR/AHB) * 64 MB of RAM * 16 MB of SPI NOR flash - 2x 7 MB available; but one of the 7 MB regions is the recovery image * 2x 10/100 Mbps Ethernet * 2T2R 2.4 GHz Wi-Fi * 6x GPIO-LEDs (3x wifi, 2x ethernet, 1x power) * 1x GPIO-button (reset) * external h/w watchdog (enabled by default) * TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX) * 2x fast ethernet - eth0 + 24V passive POE (mode B) + used as WAN interface - eth1 + 802.3af POE + builtin switch port 1 + used as LAN interface * 12-24V 1A DC * internal antennas Flashing instructions: ====================== Various methods can be used to install the actual image on the flash. Two easy ones are: ap51-flash ---------- The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be used to transfer the image to the u-boot when the device boots up. initramfs from TFTP ------------------- The serial console must be used to access the u-boot shell during bootup. It can then be used to first boot up the initramfs image from a TFTP server (here with the IP 192.168.1.21): setenv serverip 192.168.1.21 setenv ipaddr 192.168.1.1 tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr The actual sysupgrade image can then be transferred (on the LAN port) to the device via scp <filename-of-squashfs-sysupgrade>.bin root@192.168.1.1:/tmp/ On the device, the sysupgrade must then be started using sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin Signed-off-by: Sven Eckelmann <sven@narfation.org>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/dts/qca9533_openmesh_om2p-hs-v4.dts8
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/01_leds3
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/generic/base-files/lib/upgrade/platform.sh3
-rw-r--r--target/linux/ath79/image/generic.mk9
5 files changed, 22 insertions, 2 deletions
diff --git a/target/linux/ath79/dts/qca9533_openmesh_om2p-hs-v4.dts b/target/linux/ath79/dts/qca9533_openmesh_om2p-hs-v4.dts
new file mode 100644
index 0000000000..218117fd86
--- /dev/null
+++ b/target/linux/ath79/dts/qca9533_openmesh_om2p-hs-v4.dts
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9533_openmesh_om2p-v4.dtsi"
+
+/ {
+ compatible = "openmesh,om2p-hs-v4", "qca,qca9533";
+ model = "OpenMesh OM2P-HS v4";
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index 8095712e88..5795e2a0ae 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -230,7 +230,8 @@ netgear,wnr2200-16m)
ucidef_set_led_switch "lan3amber" "LAN3 (amber)" "amber:lan3" "switch0" "0x08" "0x02"
ucidef_set_led_switch "lan4amber" "LAN4 (amber)" "amber:lan4" "switch0" "0x10" "0x02"
;;
-openmesh,om2p-v4)
+openmesh,om2p-v4|\
+openmesh,om2p-hs-v4)
ucidef_set_led_netdev "wan" "WAN" "blue:wan" "eth0"
ucidef_set_led_switch "lan" "LAN" "blue:lan" "switch0" "0x02"
;;
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index fa98b18e59..f78fdeea9c 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -153,6 +153,7 @@ ath79_setup_interfaces()
comfast,cf-e314n-v2|\
compex,wpj531-16m|\
openmesh,om2p-v4|\
+ openmesh,om2p-hs-v4|\
plasmacloud,pa300|\
plasmacloud,pa300e|\
tplink,cpe210-v1|\
diff --git a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
index 88dac75301..6f0ab8f8a6 100644
--- a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
@@ -50,7 +50,8 @@ platform_do_upgrade() {
jjplus,ja76pf2)
redboot_fis_do_upgrade "$1" linux
;;
- openmesh,om2p-v4)
+ openmesh,om2p-v4|\
+ openmesh,om2p-hs-v4)
PART_NAME="inactive"
platform_do_upgrade_openmesh "$1"
;;
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 132bde73c4..66a39e06d2 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1577,6 +1577,15 @@ define Device/openmesh_om2p-v4
endef
TARGET_DEVICES += openmesh_om2p-v4
+define Device/openmesh_om2p-hs-v4
+ $(Device/openmesh_om2p-common)
+ SOC := qca9533
+ DEVICE_MODEL := OM2P-HS
+ DEVICE_VARIANT := v4
+ SUPPORTED_DEVICES += om2p-hsv4
+endef
+TARGET_DEVICES += openmesh_om2p-hs-v4
+
define Device/openmesh_om5p-ac-v2
SOC := qca9558
DEVICE_VENDOR := OpenMesh