aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRoman Kuzmitskii <damex.pp@icloud.com>2020-10-06 12:08:28 +0000
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-10-06 15:13:27 +0200
commit582ba9ddc789629a53969e5c66e19dfa183f2696 (patch)
tree5538b807c24bbc870646a66906fa24fbb24b9705 /target
parente5f7a9889cad5df86ff65689b1f0a68637e672bd (diff)
downloadupstream-582ba9ddc789629a53969e5c66e19dfa183f2696.tar.gz
upstream-582ba9ddc789629a53969e5c66e19dfa183f2696.tar.bz2
upstream-582ba9ddc789629a53969e5c66e19dfa183f2696.zip
ath79: rename ubnt,acb-isp to ubnt,aircube-isp
Use the full model name for this device to make it easier to recognize for the users and in order to make it consistent with the other devices. While at it, fix sorting in 03_gpio_switches. Signed-off-by: Roman Kuzmitskii <damex.pp@icloud.com> [commit message facelift] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/dts/qca9533_ubnt_aircube-isp.dts (renamed from target/linux/ath79/dts/qca9533_ubnt_acb-isp.dts)2
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/02_network2
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/03_gpio_switches6
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk5
4 files changed, 8 insertions, 7 deletions
diff --git a/target/linux/ath79/dts/qca9533_ubnt_acb-isp.dts b/target/linux/ath79/dts/qca9533_ubnt_aircube-isp.dts
index 449e7fe451..b74b0756fe 100644
--- a/target/linux/ath79/dts/qca9533_ubnt_acb-isp.dts
+++ b/target/linux/ath79/dts/qca9533_ubnt_aircube-isp.dts
@@ -6,7 +6,7 @@
#include <dt-bindings/input/input.h>
/ {
- compatible = "ubnt,acb-isp", "qca,qca9533";
+ compatible = "ubnt,aircube-isp", "qca,qca9533";
model = "Ubiquiti airCube ISP";
aliases {
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index bed817e286..060c0c9e42 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -349,7 +349,7 @@ ath79_setup_interfaces()
ucidef_add_switch "switch0" \
"1:lan" "2:lan" "3:lan" "4:lan" "0:wan" "9@eth0"
;;
- ubnt,acb-isp)
+ ubnt,aircube-isp)
ucidef_set_interface_wan "eth1"
ucidef_add_switch "switch0" \
"0@eth0" "2:lan:1" "3:lan:3" "4:lan:2"
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/03_gpio_switches b/target/linux/ath79/generic/base-files/etc/board.d/03_gpio_switches
index cf30bb405a..d390fdfbe2 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/03_gpio_switches
+++ b/target/linux/ath79/generic/base-files/etc/board.d/03_gpio_switches
@@ -73,6 +73,9 @@ tplink,wbs510-v1|\
tplink,wbs510-v2)
ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "20"
;;
+ubnt,aircube-isp)
+ ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "11"
+ ;;
ubnt,nanostation-ac)
ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "3"
;;
@@ -82,9 +85,6 @@ ubnt,nanostation-m)
ubnt,nanostation-m-xw)
ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "2"
;;
-ubnt,acb-isp)
- ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "11"
- ;;
zbtlink,zbt-wd323)
ucidef_add_gpio_switch "io0" "IO#0" "0"
ucidef_add_gpio_switch "io1" "IO#1" "1"
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 6939edd25d..cd67ea2904 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -110,7 +110,7 @@ define Device/ubnt-xw
UBNT_VERSION := 6.0.4
endef
-define Device/ubnt_acb-isp
+define Device/ubnt_aircube-isp
$(Device/ubnt)
SOC := qca9533
DEVICE_MODEL := airCube ISP
@@ -119,8 +119,9 @@ define Device/ubnt_acb-isp
UBNT_CHIP := qca9533
UBNT_TYPE := ACB
UBNT_VERSION := 2.5.0
+ SUPPORTED_DEVICES += ubnt,acb-isp
endef
-TARGET_DEVICES += ubnt_acb-isp
+TARGET_DEVICES += ubnt_aircube-isp
define Device/ubnt_airrouter
$(Device/ubnt-xm)