aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2018-05-04 10:27:48 -0700
committerJohn Crispin <john@phrozen.org>2018-05-05 06:55:21 +0200
commit581f5e239203df652f5a4b2ff7a22ab402735d8a (patch)
treeabc0075e3ebdd475f6c48bb8aee7e58876530d0a /target
parent22c398d2576b97b5afc67d6802528dc9eceb4d8a (diff)
downloadupstream-581f5e239203df652f5a4b2ff7a22ab402735d8a.tar.gz
upstream-581f5e239203df652f5a4b2ff7a22ab402735d8a.tar.bz2
upstream-581f5e239203df652f5a4b2ff7a22ab402735d8a.zip
at91: sdcard image with ext4 rootfs
creating sdcard image with ext4 rootfs only and ignoring creating other filesystem in sdcard image. Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/at91/image/Makefile2
-rw-r--r--target/linux/at91/image/sama5.mk3
2 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index ccaeebe7ca..93180dd64f 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -23,7 +23,7 @@ endif
define Device/Default
$(Device/default-nand)
PROFILES := Default
- FILESYSTEMS := squashfs ubifs
+ FILESYSTEMS := squashfs ubifs ext4
DEVICE_DTS := $(1)
KERNEL_NAME := zImage
KERNEL_SIZE := 4096k
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index 5960f40a3b..fd7a53421e 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -4,6 +4,7 @@ FAT32_BLOCKS:=$(shell echo \
$$(($(AT91_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
define Build/at91-sdcard
+ $(if $(findstring ext4,$@), \
rm -f $@.boot
mkfs.fat -C $@.boot $(FAT32_BLOCKS)
@@ -30,7 +31,7 @@ define Build/at91-sdcard
gzip -nc9 $@.img > $@
- rm -f $@.img $@.boot
+ rm -f $@.img $@.boot )
endef
define Device/evaluation-sdimage