aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-09-01 13:21:40 +0000
committerJohn Crispin <blogic@openwrt.org>2014-09-01 13:21:40 +0000
commit565ad00d54d82c87f7db7b5ef6dbc55573b27720 (patch)
treeddfb32fbf6b755aec65eaffa93e22683826345d1 /target
parent8af7616f33ef83e8f56a695ce2913b21afaa908d (diff)
downloadupstream-565ad00d54d82c87f7db7b5ef6dbc55573b27720.tar.gz
upstream-565ad00d54d82c87f7db7b5ef6dbc55573b27720.tar.bz2
upstream-565ad00d54d82c87f7db7b5ef6dbc55573b27720.zip
ramips: Add support for Omnima MiniPlug
This patch adds support for the Omnima MiniPlug RT5350 based board, 8MB SPI flash Signed-off-by: Ivan Ignjatic<ivan@omnima.co.uk> Backport of r42200 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42370 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/uci-defaults/01_leds4
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/OMNI-PLUG.dts113
-rw-r--r--target/linux/ramips/image/Makefile3
5 files changed, 124 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/uci-defaults/01_leds b/target/linux/ramips/base-files/etc/uci-defaults/01_leds
index cbd3ea27e4..77c2673f54 100755
--- a/target/linux/ramips/base-files/etc/uci-defaults/01_leds
+++ b/target/linux/ramips/base-files/etc/uci-defaults/01_leds
@@ -140,6 +140,10 @@ case $board in
ucidef_set_led_netdev "eth" "ETH" "emb:green:eth" "eth0"
set_wifi_led "emb:green:wifi"
;;
+ omni-plug)
+ set_wifi_led "miniplug:green:wlan"
+ set_usb_led "miniplug:green:mobile"
+ ;;
px4885)
set_wifi_led "7links:orange:wifi"
set_usb_led "7links:blue:storage"
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index cadebdf428..d2a3d9faaf 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -184,6 +184,9 @@ ramips_board_detect() {
*"Omnima MiniEMBWiFi")
name="omni-emb"
;;
+ *"Omnima MiniPlug")
+ name="omni-plug"
+ ;;
*"Petatel PSR-680W"*)
name="psr-680w"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 798a1ccd56..22b72a1920 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -64,6 +64,7 @@ platform_check_image() {
nw718 | \
omni-emb | \
omni-emb-hpm | \
+ omni-plug | \
psr-680w | \
px4885 | \
rp-n53 | \
diff --git a/target/linux/ramips/dts/OMNI-PLUG.dts b/target/linux/ramips/dts/OMNI-PLUG.dts
new file mode 100644
index 0000000000..ede0252444
--- /dev/null
+++ b/target/linux/ramips/dts/OMNI-PLUG.dts
@@ -0,0 +1,113 @@
+/dts-v1/;
+
+/include/ "rt5350.dtsi"
+
+/ {
+ compatible = "OMNI-PLUG", "ralink,rt5350-soc";
+ model = "Omnima MiniPlug";
+
+ pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "jtag", "uartf";
+ ralink,function = "gpio";
+ };
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+ wlan {
+ label = "miniplug:red:wlan";
+ gpios = <&gpio0 9 0>;
+ };
+ mobile {
+ label = "miniplug:green:mobile";
+ gpios = <&gpio0 13 1>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+ wps {
+ label = "wps";
+ gpios = <&gpio0 0 1>;
+ linux,code = <0x211>;
+ };
+ reset {
+ label = "reset";
+ gpios = <&gpio0 10 1>;
+ linux,code = <0x211>;
+ };
+ mode-one {
+ label = "mode1";
+ gpios = <&gpio0 11 1>;
+ linux,code = <0x211>;
+ };
+ mode-two {
+ label = "mode2";
+ gpios = <&gpio0 12 1>;
+ linux,code = <0x211>;
+ };
+ };
+
+ palmbus@10000000 {
+ gpio0: gpio@600 {
+ status = "okay";
+ };
+
+ spi@b00 {
+ status = "okay";
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "mx25l6405d";
+ reg = <0 0>;
+ linux,modalias = "m25p80", "mx25l6405d";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x7b0000>;
+ };
+ };
+ };
+ };
+
+ ethernet@10100000 {
+ mtd-mac-address = <&factory 0x4>;
+ };
+
+ esw@10110000 {
+ ralink,portmap = <0x2f>;
+ };
+
+ wmac@10180000 {
+ ralink,mtd-eeprom = <&factory 0>;
+ };
+
+ otg@101c0000 {
+ status = "okay";
+ };
+};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index f203312113..053dbdd5e4 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -458,6 +458,8 @@ Image/Build/Profile/NW718=$(call BuildFirmware/CustomFlashFactory/$(1),$(1),nw71
Image/Build/Profile/OMNI-EMB=$(call BuildFirmware/Default8M/$(1),$(1),omni-emb,OMNI-EMB)
+Image/Build/Profile/OMNI-PLUG=$(call BuildFirmware/Default8M/$(1),$(1),omni-plug,OMNI-PLUG)
+
Image/Build/Profile/PSR-680W=$(call BuildFirmware/Default4M/$(1),$(1),psr-680w,PSR-680W)
Image/Build/Profile/PWH2004=$(call BuildFirmware/Default8M/$(1),$(1),pwh2004,PWH2004)
@@ -604,6 +606,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/NCS601W,$(1))
$(call Image/Build/Profile/NW718,$(1))
$(call Image/Build/Profile/OMNI-EMB,$(1))
+ $(call Image/Build/Profile/OMNI-PLUG,$(1))
$(call Image/Build/Profile/PSR-680W,$(1))
$(call Image/Build/Profile/PWH2004,$(1))
$(call Image/Build/Profile/PX4885,$(1))