aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-05-18 21:10:40 +0200
committerDavid Bauer <mail@david-bauer.net>2020-05-18 21:11:22 +0200
commit564f87ef5bea16d5d1d8a9a80e8de77429159f26 (patch)
treedadca7e72b962ed3a7f091364942d2af8cecc855 /target
parent367a30389d298948a3c4867dd0261bb942371147 (diff)
downloadupstream-564f87ef5bea16d5d1d8a9a80e8de77429159f26.tar.gz
upstream-564f87ef5bea16d5d1d8a9a80e8de77429159f26.tar.bz2
upstream-564f87ef5bea16d5d1d8a9a80e8de77429159f26.zip
mpc85xx: rename generic subtarget to p1010
The mpc85xx-generic subtarget supports the QorIQ SoCs of the p1010 family. Rename the subtarget to reflect this affiliation as it's the case with the other mpc85xx subtargets. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target')
-rw-r--r--target/linux/mpc85xx/Makefile2
-rw-r--r--target/linux/mpc85xx/image/Makefile2
-rw-r--r--target/linux/mpc85xx/p1010/config-default (renamed from target/linux/mpc85xx/generic/config-default)0
-rw-r--r--target/linux/mpc85xx/p1010/profiles/00-default.mk (renamed from target/linux/mpc85xx/generic/profiles/00-default.mk)2
-rw-r--r--target/linux/mpc85xx/p1010/target.mk (renamed from target/linux/mpc85xx/generic/target.mk)4
5 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index 4bb4d8812d..2ffdfeddcd 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -11,7 +11,7 @@ BOARD:=mpc85xx
BOARDNAME:=Freescale MPC85xx
CPU_TYPE:=8540
FEATURES:=squashfs ramdisk
-SUBTARGETS:=generic p1020 p2020
+SUBTARGETS:=p1010 p1020 p2020
KERNEL_PATCHVER:=5.4
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index 40002c13c4..225f871699 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -21,7 +21,7 @@ define Device/Default
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
endef
-ifeq ($(SUBTARGET),generic)
+ifeq ($(SUBTARGET),p1010)
define Device/tplink_tl-wdr4900-v1
DEVICE_VENDOR := TP-Link
diff --git a/target/linux/mpc85xx/generic/config-default b/target/linux/mpc85xx/p1010/config-default
index e25d51aeb1..e25d51aeb1 100644
--- a/target/linux/mpc85xx/generic/config-default
+++ b/target/linux/mpc85xx/p1010/config-default
diff --git a/target/linux/mpc85xx/generic/profiles/00-default.mk b/target/linux/mpc85xx/p1010/profiles/00-default.mk
index 67507ace8a..5356aaa939 100644
--- a/target/linux/mpc85xx/generic/profiles/00-default.mk
+++ b/target/linux/mpc85xx/p1010/profiles/00-default.mk
@@ -9,7 +9,7 @@ define Profile/Default
endef
define Profile/Default/Description
- Default package set compatible with most MPC85xx boards.
+ Default package set compatible with most P1010 boards.
endef
$(eval $(call Profile,Default))
diff --git a/target/linux/mpc85xx/generic/target.mk b/target/linux/mpc85xx/p1010/target.mk
index f826fe4d15..12ed78ace1 100644
--- a/target/linux/mpc85xx/generic/target.mk
+++ b/target/linux/mpc85xx/p1010/target.mk
@@ -1,8 +1,8 @@
-BOARDNAME:=Generic
+BOARDNAME:=P1010
FEATURES+=nand
KERNELNAME:=simpleImage.tl-wdr4900-v1
define Target/Description
- Build firmware images for generic MPC85xx based boards.
+ Build firmware images for P1010 based boards.
endef
#n281'>281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417