aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-24 19:56:23 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-28 14:07:57 +0200
commit5234593462bc72582fafd0769d3b679f9b598574 (patch)
tree24c5d9ecc253da8a32713727de9cb5a2efc8b29e /target
parent0127de9547285a0cf44aea76e0a726b85d8c5235 (diff)
downloadupstream-5234593462bc72582fafd0769d3b679f9b598574.tar.gz
upstream-5234593462bc72582fafd0769d3b679f9b598574.tar.bz2
upstream-5234593462bc72582fafd0769d3b679f9b598574.zip
mvebu: move definition of factory.img out of Device/Default
The Device/Default definition in mvebu defines an IMAGE/factory.img which is not included in IMAGES, and only used twice in the individual definitions. Move it out of the default definition to keep it closer to the reassignment of IMAGES and make it more consistent with respect to other values of IMAGE/factory.img Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/mvebu/image/Makefile1
-rw-r--r--target/linux/mvebu/image/cortexa9.mk4
2 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index cbf34c1bc8..502e081ec3 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -104,7 +104,6 @@ define Device/Default
KERNEL_NAME := zImage
KERNEL := kernel-bin | append-dtb | uImage none
IMAGES := sysupgrade.bin
- IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | pad-to $$$$(PAGESIZE)
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
UBINIZE_OPTS := -E 5
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index bb09d2b6f7..f01a76a9d3 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -55,6 +55,8 @@ define Device/linksys
DEVICE_VENDOR := Linksys
DEVICE_PACKAGES := kmod-mwlwifi wpad-basic
IMAGES += factory.img
+ IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | \
+ append-ubi | pad-to $$$$(PAGESIZE)
KERNEL_SIZE := 6144k
endef
@@ -151,6 +153,8 @@ define Device/marvell_a385-db-ap
DEVICE_MODEL := Armada 385 Development Board AP (DB-88F6820-AP)
DEVICE_DTS := armada-385-db-ap
IMAGES += factory.img
+ IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | \
+ append-ubi | pad-to $$$$(PAGESIZE)
KERNEL_SIZE := 8192k
SUPPORTED_DEVICES += armada-385-db-ap
endef