aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-05-05 20:26:58 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-05-05 20:26:58 +0000
commit51ee44008242273ceee2796d97d20f45fc8680c4 (patch)
tree844a4004f922f88a270c139bfa5b79ad720764c4 /target
parented861cf5e9e7af0e25d6562baf5ebe6ef9edb6e1 (diff)
downloadupstream-51ee44008242273ceee2796d97d20f45fc8680c4.tar.gz
upstream-51ee44008242273ceee2796d97d20f45fc8680c4.tar.bz2
upstream-51ee44008242273ceee2796d97d20f45fc8680c4.zip
refresh patches
SVN-Revision: 15630
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/patches-2.6.28/101-ksz8041_phy_driver.patch8
-rw-r--r--target/linux/ar71xx/patches-2.6.28/110-usb-ehci-add-war-for-synopsys-hc-bug.patch2
-rw-r--r--target/linux/ar71xx/patches-2.6.29/101-ksz8041_phy_driver.patch10
-rw-r--r--target/linux/ar71xx/patches-2.6.30/801-ag71xx-remove-redundant-napi-functions.patch8
4 files changed, 14 insertions, 14 deletions
diff --git a/target/linux/ar71xx/patches-2.6.28/101-ksz8041_phy_driver.patch b/target/linux/ar71xx/patches-2.6.28/101-ksz8041_phy_driver.patch
index 541ae0af3d..af3cb345e5 100644
--- a/target/linux/ar71xx/patches-2.6.28/101-ksz8041_phy_driver.patch
+++ b/target/linux/ar71xx/patches-2.6.28/101-ksz8041_phy_driver.patch
@@ -1,7 +1,7 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -84,6 +84,11 @@ config IP175C_PHY
- tristate "Driver for IC+ IP175C/IP178C switches"
+@@ -88,6 +88,11 @@ config AR8216_PHY
+ tristate "Driver for Atheros AR8216 switches"
select SWCONFIG
+config MICREL_PHY
@@ -14,9 +14,9 @@
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -17,6 +17,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
- obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+@@ -18,6 +18,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
obj-$(CONFIG_IP175C_PHY) += ip175c.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
+obj-$(CONFIG_MICREL_PHY) += micrel.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
diff --git a/target/linux/ar71xx/patches-2.6.28/110-usb-ehci-add-war-for-synopsys-hc-bug.patch b/target/linux/ar71xx/patches-2.6.28/110-usb-ehci-add-war-for-synopsys-hc-bug.patch
index 3aa2479dbe..8d203e8a49 100644
--- a/target/linux/ar71xx/patches-2.6.28/110-usb-ehci-add-war-for-synopsys-hc-bug.patch
+++ b/target/linux/ar71xx/patches-2.6.28/110-usb-ehci-add-war-for-synopsys-hc-bug.patch
@@ -1,6 +1,6 @@
--- a/drivers/usb/host/ehci-q.c
+++ b/drivers/usb/host/ehci-q.c
-@@ -1050,6 +1050,9 @@ static void end_unlink_async (struct ehc
+@@ -1082,6 +1082,9 @@ static void end_unlink_async (struct ehc
ehci->reclaim = NULL;
start_unlink_async (ehci, next);
}
diff --git a/target/linux/ar71xx/patches-2.6.29/101-ksz8041_phy_driver.patch b/target/linux/ar71xx/patches-2.6.29/101-ksz8041_phy_driver.patch
index eec879660e..bd467d8472 100644
--- a/target/linux/ar71xx/patches-2.6.29/101-ksz8041_phy_driver.patch
+++ b/target/linux/ar71xx/patches-2.6.29/101-ksz8041_phy_driver.patch
@@ -1,8 +1,8 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -96,6 +96,11 @@ config ADM6996_PHY
- config MVSWITCH_PHY
- tristate "Driver for Marvell 88E6060 switches"
+@@ -104,6 +104,11 @@ config AR8216_PHY
+ tristate "Driver for Atheros AR8216 switches"
+ select SWCONFIG
+config MICREL_PHY
+ tristate "Drivers for Micrel/Kendin PHYs"
@@ -14,8 +14,8 @@
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -17,6 +17,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
- obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+@@ -19,6 +19,7 @@ obj-$(CONFIG_IP175C_PHY) += ip175c.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+obj-$(CONFIG_MICREL) += micrel.o
diff --git a/target/linux/ar71xx/patches-2.6.30/801-ag71xx-remove-redundant-napi-functions.patch b/target/linux/ar71xx/patches-2.6.30/801-ag71xx-remove-redundant-napi-functions.patch
index fbaf5d462c..281992117e 100644
--- a/target/linux/ar71xx/patches-2.6.30/801-ag71xx-remove-redundant-napi-functions.patch
+++ b/target/linux/ar71xx/patches-2.6.30/801-ag71xx-remove-redundant-napi-functions.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/ag71xx/ag71xx_main.c
+++ b/drivers/net/ag71xx/ag71xx_main.c
-@@ -557,7 +557,7 @@ static void ag71xx_oom_timer_handler(uns
+@@ -561,7 +561,7 @@ static void ag71xx_oom_timer_handler(uns
struct net_device *dev = (struct net_device *) data;
struct ag71xx *ag = netdev_priv(dev);
@@ -9,7 +9,7 @@
}
static void ag71xx_tx_timeout(struct net_device *dev)
-@@ -713,7 +713,7 @@ static int ag71xx_poll(struct napi_struc
+@@ -717,7 +717,7 @@ static int ag71xx_poll(struct napi_struc
DBG("%s: disable polling mode, done=%d, limit=%d\n",
dev->name, done, limit);
@@ -18,7 +18,7 @@
/* enable interrupts */
spin_lock_irqsave(&ag->lock, flags);
-@@ -732,7 +732,7 @@ static int ag71xx_poll(struct napi_struc
+@@ -736,7 +736,7 @@ static int ag71xx_poll(struct napi_struc
printk(KERN_DEBUG "%s: out of memory\n", dev->name);
mod_timer(&ag->oom_timer, jiffies + AG71XX_OOM_REFILL);
@@ -27,7 +27,7 @@
return 0;
}
-@@ -762,7 +762,7 @@ static irqreturn_t ag71xx_interrupt(int
+@@ -766,7 +766,7 @@ static irqreturn_t ag71xx_interrupt(int
if (likely(status & AG71XX_INT_POLL)) {
ag71xx_int_disable(ag, AG71XX_INT_POLL);
DBG("%s: enable polling mode\n", dev->name);