aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-24 20:12:10 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-24 20:12:10 +0000
commit4f3d6c9ae96524ee43891d606f6a530a2f6fb175 (patch)
tree75fbefb5ce1f3a3fd4ab68e561ab5d72d78585bf /target
parent5fa9768ceefed099928402553ccf30c2d9e58b5b (diff)
downloadupstream-4f3d6c9ae96524ee43891d606f6a530a2f6fb175.tar.gz
upstream-4f3d6c9ae96524ee43891d606f6a530a2f6fb175.tar.bz2
upstream-4f3d6c9ae96524ee43891d606f6a530a2f6fb175.zip
ar71xx: use the lzma loader on the Planex boards
SVN-Revision: 29900
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile23
1 files changed, 20 insertions, 3 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 6478245773..a5672869f1 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -87,6 +87,10 @@ define CatFiles
fi; fi
endef
+define Sysupgrade/KR
+ $(call CatFiles,$(2),$(3),$(KDIR)/root.$(1),$(4),$(call sysupname,$(1),$(5)))
+endef
+
define Sysupgrade/KRuImage
$(call CatFiles,$(KDIR_TMP)/vmlinux-$(2).uImage,$(3),$(KDIR)/root.$(1),$(4),$(call sysupname,$(1),$(2)))
endef
@@ -291,10 +295,19 @@ define Image/Build/UBNT
$(call sysupname,$(1),$(2))
endef
-planex_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1408k(kernel),6336k(rootfs),128k(art)ro,7744k@0x50000(firmware)
+planex_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,960k(kernel),6784k(rootfs),128k(art)ro,7744k@0x50000(firmware)
+define Image/Build/Planex/loader
+ $(call Image/BuildLoaderAlone,$(1),gz,$(2) $(planex_mtdlayout),0x52000,0)
+endef
+
define Image/Build/Planex
- $(call MkuImageGzip,$(2),$(3) $(planex_mtdlayout))
- $(call Sysupgrade/KRuImage,$(1),$(2),1441792,6356992)
+ $(call MkuImage,gzip,,$(KDIR)/loader-$(2).gz,$(KDIR_TMP)/vmlinux-$(2).uImage)
+ $(call MkuImageOKLI,$(2))
+ ( \
+ dd if=$(KDIR_TMP)/vmlinux-$(2).uImage bs=8k count=1 conv=sync; \
+ dd if=$(KDIR_TMP)/vmlinux-$(2).okli; \
+ ) > $(KDIR_TMP)/kernel-$(2).bin
+ $(call Sysupgrade/KR,$(1),$(KDIR_TMP)/kernel-$(2).bin,983040,6815744,$(2))
if [ -e "$(call sysupname,$(1),$(2))" ]; then \
$(STAGING_DIR_HOST)/bin/mkplanexfw \
-B $(2) \
@@ -570,6 +583,10 @@ define Image/Build/Template/squashfs-only/squashfs
$(call Image/Build/$(1),squashfs,$(2),$(3),$(4),$(5),$(6),$(7),$(8))
endef
+define Image/Build/Template/64k/loader
+ $(call Image/Build/$(1)/loader,$(2),$(3),$(4),$(5),$(6),$(7),$(8))
+endef
+
define Image/Build/Template/64k/squashfs
$(call Image/Build/$(1),squashfs-64k,$(2),$(3),$(4),$(5),$(6),$(7),$(8))
endef