aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-07 19:36:42 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-07 19:36:42 +0000
commit4edff7d3efb927e76143b3eb214699be86b635d7 (patch)
treea50f2c1249b021752b95f5b0ca12c8ce8f33ad95 /target
parent8a8e5bde15076bee23de0283154cd2aea9129021 (diff)
downloadupstream-4edff7d3efb927e76143b3eb214699be86b635d7.tar.gz
upstream-4edff7d3efb927e76143b3eb214699be86b635d7.tar.bz2
upstream-4edff7d3efb927e76143b3eb214699be86b635d7.zip
ar71xx: add a profile and build images for the TL-WR2543N/ND
SVN-Revision: 29682
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk11
-rw-r--r--target/linux/ar71xx/image/Makefile6
2 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index 2b9aa0e218..8f1314ad50 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -136,3 +136,14 @@ define Profile/TLWR1043/Description
Package set optimized for the TP-LINK TL-WR1043N/ND.
endef
$(eval $(call Profile,TLWR1043))
+
+
+define Profile/TLWR2543
+ NAME:=TP-LINK TL-WR2543N/ND
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLWR2543/Description
+ Package set optimized for the TP-LINK TL-WR2543N/ND.
+endef
+$(eval $(call Profile,TLWR2543))
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 72c5bd664a..62a6fb2524 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -854,6 +854,11 @@ define Image/Build/Profile/TLWR1043
$(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-wr1043nd-v1,$(tlwr1043_cmdline),0x10430001,1,8M)
endef
+tlwr2543_cmdline=board=TL-WR2543N console=ttyS0,115200
+define Image/Build/Profile/TLWR2543
+ $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wr2543n-v1,$(tlwr2543_cmdline),0x25430001,1,8Mlzma)
+endef
+
wndr3700_cmdline=board=WNDR3700 console=ttyS0,115200
wndr3700_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),6656k(rootfs),64k(art)ro,7680k@0x70000(firmware)
wndr3700v2_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),14848k(rootfs),64k(art)ro,15872k@0x70000(firmware)
@@ -970,6 +975,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/TLWR841,$(1))
$(call Image/Build/Profile/TLWR941,$(1))
$(call Image/Build/Profile/TLWR1043,$(1))
+ $(call Image/Build/Profile/TLWR2543,$(1))
$(call Image/Build/Profile/UBNT,$(1))
$(call Image/Build/Profile/WP543,$(1))
$(call Image/Build/Profile/WNDR3700,$(1))