aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorClaudio Leite <leitec@gmail.com>2017-02-05 03:59:45 -0500
committerJohn Crispin <john@phrozen.org>2017-02-08 06:16:53 +0100
commit4e2c2b51f51e3f2643d5c781dfeed99c4d1adc38 (patch)
tree083d1582e10c1979d1497efe8c04719e7fb8a963 /target
parent86bd88669704ca02fbdb34cdcb7366bfc12b39a9 (diff)
downloadupstream-4e2c2b51f51e3f2643d5c781dfeed99c4d1adc38.tar.gz
upstream-4e2c2b51f51e3f2643d5c781dfeed99c4d1adc38.tar.bz2
upstream-4e2c2b51f51e3f2643d5c781dfeed99c4d1adc38.zip
ramips: fix AR670W partition alignment
mtdsplit_lzma requires that the rootfs be aligned to a block boundary. Pad the kernel partition to make this so. Signed-off-by: Claudio Leite <leitec@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/rt288x.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/rt288x.mk b/target/linux/ramips/image/rt288x.mk
index f22182fbf2..93cdda519c 100644
--- a/target/linux/ramips/image/rt288x.mk
+++ b/target/linux/ramips/image/rt288x.mk
@@ -14,7 +14,7 @@ define Device/ar670w
BLOCKSIZE := 64k
DEVICE_TITLE := Airlink AR670W
IMAGE_SIZE := $(ralink_default_fw_size_4M)
- KERNEL := $(KERNEL_DTB)
+ KERNEL := $(KERNEL_DTB) | pad-to $$(BLOCKSIZE)
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
wrg-header wrgn16a_airlink_ar670w