aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorAmir Rachum <amir@rachum.com>2016-10-08 13:51:51 +0300
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-10-09 21:13:09 +0200
commit4c36bcc567af822163d87f7bf89c5f8e81da93ea (patch)
tree5078b843fc48a38840bfd5b42c15c58730930a41 /target
parent175b59c59b7cd8f40bdb3a8f3c6fec05e46c5299 (diff)
downloadupstream-4c36bcc567af822163d87f7bf89c5f8e81da93ea.tar.gz
upstream-4c36bcc567af822163d87f7bf89c5f8e81da93ea.tar.bz2
upstream-4c36bcc567af822163d87f7bf89c5f8e81da93ea.zip
ar71xx: build image for Archer C7 v2 IL
TP-Link uses a different region coding mechanism for IL firmware for the Archer C7 v2. Instead of of setting the region, they set a different TPLINK_HWREV. Signed-off-by: Amir Rachum <amir@rachum.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/tp-link.mk12
1 files changed, 11 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/tp-link.mk b/target/linux/ar71xx/image/tp-link.mk
index da96813167..fde14b2ec6 100644
--- a/target/linux/ar71xx/image/tp-link.mk
+++ b/target/linux/ar71xx/image/tp-link.mk
@@ -217,6 +217,16 @@ define Device/archer-c7-v2
IMAGE/factory-eu.bin := append-rootfs | mktplinkfw factory -C EU
endef
+define Device/archer-c7-v2-il
+ $(Device/tplink-16mlzma)
+ DEVICE_TITLE := TP-LINK Archer C7 v2 IL
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev kmod-ath10k ath10k-firmware-qca988x
+ BOARDNAME := ARCHER-C7-V2
+ DEVICE_PROFILE := ARCHERC7
+ TPLINK_HWID := 0xc7000002
+ TPLINK_HWREV := 0x494c0001
+endef
+
define Device/tl-wdr7500-v3
$(Device/tplink-8mlzma)
DEVICE_TITLE := TP-LINK Archer C7 v3
@@ -225,7 +235,7 @@ define Device/tl-wdr7500-v3
DEVICE_PROFILE := ARCHERC7
TPLINK_HWID := 0x75000003
endef
-TARGET_DEVICES += archer-c5-v1 archer-c7-v1 archer-c7-v2 tl-wdr7500-v3
+TARGET_DEVICES += archer-c5-v1 archer-c7-v1 archer-c7-v2 archer-c7-v2-il tl-wdr7500-v3
define Device/tl-mr10u-v1
$(Device/tplink-4mlzma)