aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-01-02 15:07:39 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-01-02 15:07:39 +0000
commit466e84e144ac6b659fddc96ac7d6b12efd01a096 (patch)
treea3a40142a12a3d1ddd5b20f04c1464806301624c /target
parente564b686b86316abb37aa09a553d6c009e383968 (diff)
downloadupstream-466e84e144ac6b659fddc96ac7d6b12efd01a096.tar.gz
upstream-466e84e144ac6b659fddc96ac7d6b12efd01a096.tar.bz2
upstream-466e84e144ac6b659fddc96ac7d6b12efd01a096.zip
adm5120: add kmod-leds-gpio and kmod-ledtrig-adm5120-switch to the default packages
SVN-Revision: 19001
Diffstat (limited to 'target')
-rw-r--r--target/linux/adm5120/Makefile3
-rwxr-xr-xtarget/linux/adm5120/base-files/etc/diag.sh1
2 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/adm5120/Makefile b/target/linux/adm5120/Makefile
index bcafec0b77..8bd1eb11a5 100644
--- a/target/linux/adm5120/Makefile
+++ b/target/linux/adm5120/Makefile
@@ -16,6 +16,7 @@ INITRAMFS_EXTRA_FILES:=
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += admswconfig hostapd-mini kmod-input-core \
- kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug
+ kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug \
+ kmod-leds-gpio kmod-ledtrig-adm5120-switch
$(eval $(call BuildTarget))
diff --git a/target/linux/adm5120/base-files/etc/diag.sh b/target/linux/adm5120/base-files/etc/diag.sh
index e031755239..3a66dfc87b 100755
--- a/target/linux/adm5120/base-files/etc/diag.sh
+++ b/target/linux/adm5120/base-files/etc/diag.sh
@@ -35,6 +35,7 @@ status_led_off() {
set_state() {
case "$1" in
preinit)
+ insmod leds-gpio
status_led_set_timer 200 200
;;
failsafe)