aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDaniel Dickinson <crazycshore@gmail.com>2010-12-10 18:59:58 +0000
committerDaniel Dickinson <crazycshore@gmail.com>2010-12-10 18:59:58 +0000
commit44e22cbd49deeb17e9033da8bc72059887acb92f (patch)
tree27b93a722723b7f3b5a80149a75ecb7578d6e9fb /target
parent4dcba4234223d83e60640e62a0c959aea2eb657c (diff)
downloadupstream-44e22cbd49deeb17e9033da8bc72059887acb92f.tar.gz
upstream-44e22cbd49deeb17e9033da8bc72059887acb92f.tar.bz2
upstream-44e22cbd49deeb17e9033da8bc72059887acb92f.zip
Fixed Comtrend CT536_CT5621 board settings. These boards are based on the 96348GW-11 reference design but have different GPIOs therefore we use the board fixups now availabed (thanks the patches by Jonas Gorski) to create a separate board entry for these boards and leave the reference design with reference GPIOs. Also these boards only have enet1 (no enet0) so we set that in the board definition, and use a defconfig for a single interface network.
SVN-Revision: 24442
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm63xx/base-files/etc/defconfig/CT536_CT5621/network14
-rwxr-xr-xtarget/linux/brcm63xx/base-files/lib/brcm63xx.sh5
-rw-r--r--target/linux/brcm63xx/image/Makefile4
-rw-r--r--target/linux/brcm63xx/patches-2.6.35/440-new_96348gw-11_leds.patch60
4 files changed, 82 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/base-files/etc/defconfig/CT536_CT5621/network b/target/linux/brcm63xx/base-files/etc/defconfig/CT536_CT5621/network
new file mode 100644
index 0000000000..a35fd2ef9a
--- /dev/null
+++ b/target/linux/brcm63xx/base-files/etc/defconfig/CT536_CT5621/network
@@ -0,0 +1,14 @@
+# Copyright (C) 2006 OpenWrt.org
+
+config interface loopback
+ option ifname lo
+ option proto static
+ option ipaddr 127.0.0.1
+ option netmask 255.0.0.0
+
+config interface lan
+ option ifname eth0
+ option type bridge
+ option proto static
+ option ipaddr 192.168.1.1
+ option netmask 255.255.255.0
diff --git a/target/linux/brcm63xx/base-files/lib/brcm63xx.sh b/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
index e2c563460a..71c188022c 100755
--- a/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
+++ b/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
@@ -34,6 +34,11 @@ brcm63xx_detect() {
brcm63xx_has_reset_button="true"
ifname=eth1
;;
+ "bcm63xx/CT536_CT5621 "*)
+ status_led="power"
+ brcm63xx_has_reset_button="true"
+ ifname=eth0
+ ;;
"bcm63xx/96358GW "* | "bcm63xx/SPW500V "*)
status_led="power:green"
brcm63xx_has_reset_button="true"
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 25c9b36a49..b34c7eb5dc 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -128,6 +128,8 @@ define Image/Build
$(call Image/Build/CFE,$(1),96348GW,6348,96348GW-bc221,,--layoutver 5)
$(call Image/Build/CFE,$(1),6338GW,6338,6338GW-generic,,)
$(call Image/Build/CFE,$(1),6338W,6338,6338W-generic,,)
+ $(call Image/Build/CFE,$(1),96348GW-11,6348,96348GW-11-gen)
+ $(call Image/Build/CFE,$(1),96348GW-10,6348,96348GW-10-gen)
# BT Voyager V210_BTR
$(call Image/Build/CFE,$(1),V210_BB,6348,BTV210_BTR,,--layoutver 5)
@@ -152,7 +154,7 @@ define Image/Build
# Neufbox4
$(call Image/Build/CFE,$(1),96358VW,6358,NEUFBOX4,OpenWRT-$(REVISION))
# Comtrend 536, 5621
- $(call Image/Build/CFE,$(1),96348GW-11,6348,CT536_CT5621)
+ $(call Image/Build/CFEFIXUP,$(1),96348GW-11,6348,CT536_CT5621)
# Davolink DV201AMR
$(call Image/Build/CFEOLD,$(1),DV201AMR,6348)
# USR 9108
diff --git a/target/linux/brcm63xx/patches-2.6.35/440-new_96348gw-11_leds.patch b/target/linux/brcm63xx/patches-2.6.35/440-new_96348gw-11_leds.patch
new file mode 100644
index 0000000000..e1b6342655
--- /dev/null
+++ b/target/linux/brcm63xx/patches-2.6.35/440-new_96348gw-11_leds.patch
@@ -0,0 +1,60 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -364,6 +364,49 @@ static struct board_info __initdata boar
+ },
+ };
+
++static struct board_info __initdata board_ct536_ct5621 = {
++ .name = "CT536_CT5621",
++ .expected_cpu_id = 0x6348,
++
++ .has_uart0 = 1,
++ .has_enet0 = 0,
++ .has_enet1 = 1,
++ .has_pci = 1,
++
++ .enet1 = {
++ .force_speed_100 = 1,
++ .force_duplex_full = 1,
++ },
++
++ .has_ohci0 = 1,
++ .has_pccard = 1,
++ .has_ehci0 = 1,
++
++ .leds = {
++ {
++ .name = "adsl-fail",
++ .gpio = 2,
++ .active_low = 1,
++ },
++ {
++ .name = "power",
++ .gpio = 0,
++ .active_low = 1,
++ .default_trigger = "default-on",
++ },
++ },
++ .buttons = {
++ {
++ .desc = "reset",
++ .gpio = 33,
++ .active_low = 1,
++ .type = EV_KEY,
++ .code = KEY_RESTART,
++ .threshold = 3,
++ },
++ },
++};
++
+ static struct board_info __initdata board_96348gw = {
+ .name = "96348GW",
+ .expected_cpu_id = 0x6348,
+@@ -1642,6 +1685,7 @@ static const struct board_info __initdat
+ &board_rta1025w_16,
+ &board_96348_D4PW,
+ &board_spw500v,
++ &board_ct536_ct5621,
+ #endif
+
+ #ifdef CONFIG_BCM63XX_CPU_6358