aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
author张鹏 <sd20@qxwlan.com>2020-10-31 09:35:21 +0800
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-11-12 17:18:26 +0100
commit448de2e2e5c2c00a11bdf08147ee85242b2d48d2 (patch)
treef4967d1013ee44f42d37e059cb71608dc0fab92c /target
parent75401550c34f6c67eadcbafe2d430cfbf5a90647 (diff)
downloadupstream-448de2e2e5c2c00a11bdf08147ee85242b2d48d2.tar.gz
upstream-448de2e2e5c2c00a11bdf08147ee85242b2d48d2.tar.bz2
upstream-448de2e2e5c2c00a11bdf08147ee85242b2d48d2.zip
ath79: add support for Qxwlan E600G v2 / E600GAC v2
E600G v2 based on Qualcomm/Atheros QCA9531 Specification: - 650/600/200 MHz (CPU/DDR/AHB) - 128/64 MB of RAM (DDR2) - 8/16 MB of FLASH (SPI NOR) - 2T2R 2.4 GHz - 2 x 10/100 Mbps Ethernet(RJ45) - 1 x MiniPCI-e - 1 x SIM (3G/4G) - 5 x LED , 1 x Button(SW2-Reset Buttun), 1 x power input - UART(J100) header on PCB(115200 8N1) E600GAC v2 based on Qualcomm/Atheros QCA9531 + QCA9887 Specification: - 650/600/200 MHz (CPU/DDR/AHB) - 128/64 MB of RAM (DDR2) - 8/16 MB of FLASH (SPI NOR) - 2T2R 2.4 GHz - 1T1R 5 GHz - 2 x 10/100 Mbps Ethernet(RJ45) - 6 x LED (one three-color led), 2 x Button(SW2-Reset Buttun),1 x power input - UART (J100)header on PCB(115200 8N1) Flash instruction: 1.Using tftp mode with UART connection and original OpenWrt image - Configure PC with static IP 192.168.1.10 and tftp server. - Rename "openwrt-ath79-generic-xxx-squashfs-sysupgrade.bin" to "firmware.bin" and place it in tftp server directory. - Connect PC with one of LAN ports, power up the router and press key "Enter" to access U-Boot CLI. - Use the following commands to update the device to OpenWrt: run lfw - After that the device will reboot and boot to OpenWrt. - Wait until all LEDs stops flashing and use the router. 2.Using httpd mode with Web UI connection and original OpenWrt image - Configure PC with static IP 192.168.1.xxx(2-255) and tftp server. - Connect PC with one of LAN ports,press the reset button, power up the router and keep button pressed for around 6-7 seconds, until leds flashing. - Open your browser and enter 192.168.1.1,You will see the upgrade interface, select "openwrt-ath79-generic-xxx-squashfs- sysupgrade.bin" and click the upgrade button. - After that the device will reboot and boot to OpenWrt. - Wait until all LEDs stops flashing and use the router. Signed-off-by: 张鹏 <sd20@qxwlan.com> [rearrange in generic.mk, fix one case in 04_led_migration, update commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/dts/qca9531_qxwlan_e600g-v2-16m.dts32
-rw-r--r--target/linux/ath79/dts/qca9531_qxwlan_e600g-v2-8m.dts32
-rw-r--r--target/linux/ath79/dts/qca9531_qxwlan_e600g.dtsi114
-rw-r--r--target/linux/ath79/dts/qca9531_qxwlan_e600gac-v2-16m.dts48
-rw-r--r--target/linux/ath79/dts/qca9531_qxwlan_e600gac-v2-8m.dts48
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/01_leds4
-rw-r--r--target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata2
-rw-r--r--target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration8
-rw-r--r--target/linux/ath79/image/generic.mk44
9 files changed, 332 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/qca9531_qxwlan_e600g-v2-16m.dts b/target/linux/ath79/dts/qca9531_qxwlan_e600g-v2-16m.dts
new file mode 100644
index 0000000000..9b4c0a514d
--- /dev/null
+++ b/target/linux/ath79/dts/qca9531_qxwlan_e600g-v2-16m.dts
@@ -0,0 +1,32 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9531_qxwlan_e600g.dtsi"
+
+/ {
+ model = "Qxwlan E600G v2 16M";
+ compatible = "qxwlan,e600g-v2-16m", "qca,qca9531";
+};
+
+&leds {
+ wlan {
+ label = "blue:wlan";
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+};
+
+&partitions {
+ partition@70000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x070000 0xf90000>;
+ };
+};
+
+&usb_phy {
+ status = "okay";
+};
+
+&usb0 {
+ status = "okay";
+};
diff --git a/target/linux/ath79/dts/qca9531_qxwlan_e600g-v2-8m.dts b/target/linux/ath79/dts/qca9531_qxwlan_e600g-v2-8m.dts
new file mode 100644
index 0000000000..7822ec664a
--- /dev/null
+++ b/target/linux/ath79/dts/qca9531_qxwlan_e600g-v2-8m.dts
@@ -0,0 +1,32 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9531_qxwlan_e600g.dtsi"
+
+/ {
+ model = "Qxwlan E600G v2 8M";
+ compatible = "qxwlan,e600g-v2-8m", "qca,qca9531";
+};
+
+&leds {
+ wlan {
+ label = "blue:wlan";
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+};
+
+&partitions {
+ partition@70000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x070000 0x790000>;
+ };
+};
+
+&usb_phy {
+ status = "okay";
+};
+
+&usb0 {
+ status = "okay";
+};
diff --git a/target/linux/ath79/dts/qca9531_qxwlan_e600g.dtsi b/target/linux/ath79/dts/qca9531_qxwlan_e600g.dtsi
new file mode 100644
index 0000000000..6ba4ae8fdf
--- /dev/null
+++ b/target/linux/ath79/dts/qca9531_qxwlan_e600g.dtsi
@@ -0,0 +1,114 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca953x.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ aliases {
+ label-mac-device = &eth0;
+ led-boot = &led_system;
+ led-failsafe = &led_system;
+ led-running = &led_system;
+ led-upgrade = &led_system;
+ };
+
+ keys: keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+ };
+
+ leds: leds {
+ compatible = "gpio-leds";
+
+ led_system: system {
+ label = "blue:system";
+ gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+ default-state = "on";
+ };
+
+ wan {
+ label = "green:wan";
+ gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+ };
+
+ lan {
+ label = "green:lan";
+ gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&pcie0 {
+ status = "okay";
+};
+
+&spi {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions: partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x040000>;
+ read-only;
+ };
+
+ partition@40000 {
+ label = "u-boot-env";
+ reg = <0x040000 0x010000>;
+ read-only;
+ };
+
+ pridata: partition@50000 {
+ label = "pri-data";
+ reg = <0x050000 0x010000>;
+ read-only;
+ };
+
+ art: partition@60000 {
+ label = "art";
+ reg = <0x060000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&eth0 {
+ status = "okay";
+
+ phy-handle = <&swphy4>;
+
+ mtd-mac-address = <&pridata 0x400>;
+ mtd-mac-address-increment = <1>;
+};
+
+&eth1 {
+ mtd-mac-address = <&pridata 0x400>;
+};
+
+&uart {
+ status = "okay";
+};
+
+&wmac {
+ status = "okay";
+
+ mtd-cal-data = <&art 0x1000>;
+};
diff --git a/target/linux/ath79/dts/qca9531_qxwlan_e600gac-v2-16m.dts b/target/linux/ath79/dts/qca9531_qxwlan_e600gac-v2-16m.dts
new file mode 100644
index 0000000000..4be24986df
--- /dev/null
+++ b/target/linux/ath79/dts/qca9531_qxwlan_e600gac-v2-16m.dts
@@ -0,0 +1,48 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9531_qxwlan_e600g.dtsi"
+
+/ {
+ model = "Qxwlan E600GAC v2 16M";
+ compatible = "qxwlan,e600gac-v2-16m", "qca,qca9531";
+};
+
+&keys {
+ wps {
+ label = "wps";
+ linux,code = <KEY_WPS_BUTTON>;
+ gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+};
+
+&leds {
+ wlan2g {
+ label = "orange:wlan2g";
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy1tpt";
+ };
+
+ control1 {
+ label = "green:control";
+ gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+ };
+
+ control2 {
+ label = "red:control";
+ gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+ };
+
+ control3 {
+ label = "blue:control";
+ gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+ };
+};
+
+&partitions {
+ partition@70000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x070000 0xf90000>;
+ };
+};
diff --git a/target/linux/ath79/dts/qca9531_qxwlan_e600gac-v2-8m.dts b/target/linux/ath79/dts/qca9531_qxwlan_e600gac-v2-8m.dts
new file mode 100644
index 0000000000..826c46b2a1
--- /dev/null
+++ b/target/linux/ath79/dts/qca9531_qxwlan_e600gac-v2-8m.dts
@@ -0,0 +1,48 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9531_qxwlan_e600g.dtsi"
+
+/ {
+ model = "Qxwlan E600GAC v2 8M";
+ compatible = "qxwlan,e600gac-v2-8m", "qca,qca9531";
+};
+
+&keys {
+ wps {
+ label = "wps";
+ linux,code = <KEY_WPS_BUTTON>;
+ gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+};
+
+&leds {
+ wlan2g {
+ label = "orange:wlan2g";
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy1tpt";
+ };
+
+ control1 {
+ label = "green:control";
+ gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+ };
+
+ control2 {
+ label = "red:control";
+ gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+ };
+
+ control3 {
+ label = "blue:control";
+ gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+ };
+};
+
+&partitions {
+ partition@70000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x070000 0x790000>;
+ };
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index 0c130e329e..227e64678d 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -195,6 +195,10 @@ etactica,eg200)
ucidef_set_led_oneshot "modbus" "Modbus" "red:modbus" "100" "33"
;;
glinet,gl-mifi|\
+qxwlan,e600g-v2-8m|\
+qxwlan,e600g-v2-16m|\
+qxwlan,e600gac-v2-8m|\
+qxwlan,e600gac-v2-16m|\
qxwlan,e750a-v4-8m|\
qxwlan,e750a-v4-16m)
ucidef_set_led_switch "lan" "LAN" "green:lan" "switch0" "0x02"
diff --git a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index 25e864ba72..e968658cac 100644
--- a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -24,6 +24,8 @@ case "$FIRMWARE" in
devolo,magic-2-wifi|\
qxwlan,e1700ac-v2-8m|\
qxwlan,e1700ac-v2-16m|\
+ qxwlan,e600gac-v2-8m|\
+ qxwlan,e600gac-v2-16m|\
ubnt,unifiac-lite|\
ubnt,unifiac-lr|\
ubnt,unifiac-mesh|\
diff --git a/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration b/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
index 0efc2bf9d7..231afd9f57 100644
--- a/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
+++ b/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
@@ -24,6 +24,14 @@ qxwlan,e558-v2-16m|\
qxwlan,e558-v2-8m)
migrate_leds ":qss=:sig2"
;;
+qxwlan,e600g-v2-16m|\
+qxwlan,e600g-v2-8m)
+ migrate_leds "blue:wan=blue:wlan"
+ ;;
+qxwlan,e600gac-v2-16m|\
+qxwlan,e600gac-v2-8m)
+ migrate_leds "orange:wan=orange:wlan2g" "green:system=blue:system"
+ ;;
qxwlan,e750a-v4-16m|\
qxwlan,e750a-v4-8m|\
qxwlan,e750g-v8-16m|\
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 1c2c805b2a..dc91e1b6d9 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1513,6 +1513,50 @@ define Device/qxwlan_e558-v2-8m
endef
TARGET_DEVICES += qxwlan_e558-v2-8m
+define Device/qxwlan_e600g-v2
+ SOC := qca9531
+ DEVICE_VENDOR := Qxwlan
+ DEVICE_MODEL := E600G
+ DEVICE_PACKAGES := kmod-usb2
+ SUPPORTED_DEVICES += e600g-v2
+endef
+
+define Device/qxwlan_e600g-v2-16m
+ $(Device/qxwlan_e600g-v2)
+ DEVICE_VARIANT := v2 (16M)
+ IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += qxwlan_e600g-v2-16m
+
+define Device/qxwlan_e600g-v2-8m
+ $(Device/qxwlan_e600g-v2)
+ DEVICE_VARIANT := v2 (8M)
+ IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += qxwlan_e600g-v2-8m
+
+define Device/qxwlan_e600gac-v2
+ SOC := qca9531
+ DEVICE_VENDOR := Qxwlan
+ DEVICE_MODEL := E600GAC
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9887-ct
+ SUPPORTED_DEVICES += e600gac-v2
+endef
+
+define Device/qxwlan_e600gac-v2-16m
+ $(Device/qxwlan_e600gac-v2)
+ DEVICE_VARIANT := v2 (16M)
+ IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += qxwlan_e600gac-v2-16m
+
+define Device/qxwlan_e600gac-v2-8m
+ $(Device/qxwlan_e600gac-v2)
+ DEVICE_VARIANT := v2 (8M)
+ IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += qxwlan_e600gac-v2-8m
+
define Device/qxwlan_e750a-v4
SOC := ar9344
DEVICE_VENDOR := Qxwlan