aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-07-02 16:37:23 +0000
committerJohn Crispin <blogic@openwrt.org>2014-07-02 16:37:23 +0000
commit3fff418f140ff982a24e935b00887ed11e4d2e52 (patch)
tree587174c3404bd50d60f7e4fd1c7ceb6bd11f82a2 /target
parente09682fd7beca20423296b8ff6b425c94b1e1452 (diff)
downloadupstream-3fff418f140ff982a24e935b00887ed11e4d2e52.tar.gz
upstream-3fff418f140ff982a24e935b00887ed11e4d2e52.tar.bz2
upstream-3fff418f140ff982a24e935b00887ed11e4d2e52.zip
lantiq: UbinizeImage instead of lantiq-specific ubinize.cfg files
New make target in lantiq to use UbinizeImage and SysupgradeNand. Only enabled for BTHOMEHUBV2B for the moment but should be useable for other lantiq nand boards. Signed-off-by: Ben Mulvihill <ben.mulvihill@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41474 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/lantiq/image/Makefile24
1 files changed, 23 insertions, 1 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 7d95061b54..768b227e62 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -12,6 +12,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
JFFS2_BLOCKSIZE = 64k 128k 256k
+KDIR_TMP:=$(KDIR)/tmp
LOADER_MAKE := $(NO_TRACE_MAKE) -C lzma-loader KDIR=$(KDIR)
@@ -82,6 +83,15 @@ define Image/Build/squashfs
$(if $(3),$(call MkBrnImage,$(3),$(4),$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(3)-brnImage,$(2),$(1),$(5)))
endef
+define Image/BuildNAND/squashfs
+
+ifneq ($($(PROFILE)_UBI_OPTS),)
+ $(call prepare_generic_squashfs,$(KDIR)/root.$(1))
+ $(call Image/Build/UbinizeImage,$(PROFILE),,squashfs,$($(PROFILE)_UBI_OPTS))
+ $(call Image/Build/SysupgradeNAND,$(PROFILE),$(1),$(KDIR)/uImage-$(PROFILE))
+endif
+endef
+
DGN3500_SKERNEL=0x50000
DGN3500_SKERNEL_DECIMAL=327680
define Image/BuildDGN3500/squashfs
@@ -185,6 +195,18 @@ ifneq ($($(PROFILE)_UBI_OPTS),)
endif
endef
+
+define Image/BuildNAND/ubifs
+
+ifneq ($($(PROFILE)_UBIFS_OPTS),)
+ifneq ($($(PROFILE)_UBI_OPTS),)
+ $(call Image/Build/UbinizeImage,$(PROFILE),,ubifs,$($(PROFILE)_UBI_OPTS))
+ $(call Image/Build/SysupgradeNAND,$(PROFILE),$(1),$(KDIR)/uImage-$(PROFILE))
+endif
+endif
+endef
+
+
define Image/InstallKernel/Template
ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
@@ -293,7 +315,7 @@ ifeq ($(CONFIG_TARGET_lantiq_xway),y)
# Danube
Image/BuildKernel/Profile/BTHOMEHUBV2B=$(call Image/BuildKernel/Template,BTHOMEHUBV2B)
-Image/Build/Profile/BTHOMEHUBV2B=$(call Image/Build/$(1),$(1),BTHOMEHUBV2B)
+Image/Build/Profile/BTHOMEHUBV2B=$(call Image/BuildNAND/$(1),$(1),BTHOMEHUBV2B)
Image/BuildKernel/Profile/EASY50712=$(call Image/BuildKernel/Template,EASY50712)
Image/Build/Profile/EASY50712=$(call Image/Build/$(1),$(1),EASY50712)